[4.2.0.M1] - Error installing Activemq

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[4.2.0.M1] - Error installing Activemq

fpapon
Hi,

I've got an error when installing activemq feature link to the version
of felix gogo command :

karaf@root()> feature:install activemq
Error executing command: Unable to resolve root: missing requirement
[root] osgi.identity; osgi.identity=activemq; type=karaf.feature;
version="[5.15.2,5.15.2]";
filter:="(&(osgi.identity=activemq)(type=karaf.feature)(version>=5.15.2)(version<=5.15.2))"
[caused by: Unable to resolve activemq/5.15.2: missing requirement
[activemq/5.15.2] osgi.identity; osgi.identity=activemq-karaf;
type=osgi.bundle; version="[5.15.2,5.15.2]"; resolution:=mandatory
[caused by: Unable to resolve activemq-karaf/5.15.2: missing requirement
[activemq-karaf/5.15.2] osgi.wiring.package;
filter:="(&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))"]]


François Papon
fpapon@apache.org
Yupiik - https://www.yupiik.com
Reply | Threaded
Open this post in threaded view
|

Re: [4.2.0.M1] - Error installing Activemq

Guillaume Nodet-2
You need to install the shell-compat feature along with activemq.

2017-11-11 17:58 GMT+01:00 Francois Papon <[hidden email]>:

> Hi,
>
> I've got an error when installing activemq feature link to the version
> of felix gogo command :
>
> karaf@root()> feature:install activemq
> Error executing command: Unable to resolve root: missing requirement
> [root] osgi.identity; osgi.identity=activemq; type=karaf.feature;
> version="[5.15.2,5.15.2]";
> filter:="(&(osgi.identity=activemq)(type=karaf.feature)(
> version>=5.15.2)(version<=5.15.2))"
> [caused by: Unable to resolve activemq/5.15.2: missing requirement
> [activemq/5.15.2] osgi.identity; osgi.identity=activemq-karaf;
> type=osgi.bundle; version="[5.15.2,5.15.2]"; resolution:=mandatory
> [caused by: Unable to resolve activemq-karaf/5.15.2: missing requirement
> [activemq-karaf/5.15.2] osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.felix.gogo.
> commands)(version>=0.16.0)(!(version>=1.0.0)))"]]
>
>
>


--
------------------------
Guillaume Nodet
Reply | Threaded
Open this post in threaded view
|

Re: [4.2.0.M1] - Error installing Activemq

jbonofre
In reply to this post by fpapon
Hi,

you have to install the shell-compat feature to provide felix gogo commands.

Regards
JB

On 11/11/2017 05:58 PM, Francois Papon wrote:

> Hi,
>
> I've got an error when installing activemq feature link to the version
> of felix gogo command :
>
> karaf@root()> feature:install activemq
> Error executing command: Unable to resolve root: missing requirement
> [root] osgi.identity; osgi.identity=activemq; type=karaf.feature;
> version="[5.15.2,5.15.2]";
> filter:="(&(osgi.identity=activemq)(type=karaf.feature)(version>=5.15.2)(version<=5.15.2))"
> [caused by: Unable to resolve activemq/5.15.2: missing requirement
> [activemq/5.15.2] osgi.identity; osgi.identity=activemq-karaf;
> type=osgi.bundle; version="[5.15.2,5.15.2]"; resolution:=mandatory
> [caused by: Unable to resolve activemq-karaf/5.15.2: missing requirement
> [activemq-karaf/5.15.2] osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))"]]
>
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

Re: [4.2.0.M1] - Error installing Activemq

fpapon
In reply to this post by Guillaume Nodet-2
Ok, it work's

Thanks

Le 11/11/2017 à 23:11, Guillaume Nodet a écrit :

> You need to install the shell-compat feature along with activemq.
>
> 2017-11-11 17:58 GMT+01:00 Francois Papon <[hidden email]>:
>
>> Hi,
>>
>> I've got an error when installing activemq feature link to the version
>> of felix gogo command :
>>
>> karaf@root()> feature:install activemq
>> Error executing command: Unable to resolve root: missing requirement
>> [root] osgi.identity; osgi.identity=activemq; type=karaf.feature;
>> version="[5.15.2,5.15.2]";
>> filter:="(&(osgi.identity=activemq)(type=karaf.feature)(
>> version>=5.15.2)(version<=5.15.2))"
>> [caused by: Unable to resolve activemq/5.15.2: missing requirement
>> [activemq/5.15.2] osgi.identity; osgi.identity=activemq-karaf;
>> type=osgi.bundle; version="[5.15.2,5.15.2]"; resolution:=mandatory
>> [caused by: Unable to resolve activemq-karaf/5.15.2: missing requirement
>> [activemq-karaf/5.15.2] osgi.wiring.package;
>> filter:="(&(osgi.wiring.package=org.apache.felix.gogo.
>> commands)(version>=0.16.0)(!(version>=1.0.0)))"]]
>>
>>
>>
>

François Papon
fpapon@apache.org
Yupiik - https://www.yupiik.com
Reply | Threaded
Open this post in threaded view
|

Re: [4.2.0.M1] - Error installing Activemq

fpapon
In reply to this post by jbonofre
Ok, it work's.

Thanks

Did this dependency should be add in the activemq karaf feature in a
future version ?


Le 12/11/2017 à 10:29, Jean-Baptiste Onofré a écrit :

> Hi,
>
> you have to install the shell-compat feature to provide felix gogo
> commands.
>
> Regards
> JB
>
> On 11/11/2017 05:58 PM, Francois Papon wrote:
>> Hi,
>>
>> I've got an error when installing activemq feature link to the version
>> of felix gogo command :
>>
>> karaf@root()> feature:install activemq
>> Error executing command: Unable to resolve root: missing requirement
>> [root] osgi.identity; osgi.identity=activemq; type=karaf.feature;
>> version="[5.15.2,5.15.2]";
>> filter:="(&(osgi.identity=activemq)(type=karaf.feature)(version>=5.15.2)(version<=5.15.2))"
>>
>> [caused by: Unable to resolve activemq/5.15.2: missing requirement
>> [activemq/5.15.2] osgi.identity; osgi.identity=activemq-karaf;
>> type=osgi.bundle; version="[5.15.2,5.15.2]"; resolution:=mandatory
>> [caused by: Unable to resolve activemq-karaf/5.15.2: missing requirement
>> [activemq-karaf/5.15.2] osgi.wiring.package;
>> filter:="(&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))"]]
>>
>>
>>
>

François Papon
fpapon@apache.org
Yupiik - https://www.yupiik.com
Reply | Threaded
Open this post in threaded view
|

Re: [4.2.0.M1] - Error installing Activemq

jbonofre
Yes, probably at least for the transition to the new commands layer.

Regards
JB

On 11/12/2017 10:41 AM, Francois Papon wrote:

> Ok, it work's.
>
> Thanks
>
> Did this dependency should be add in the activemq karaf feature in a
> future version ?
>
>
> Le 12/11/2017 à 10:29, Jean-Baptiste Onofré a écrit :
>> Hi,
>>
>> you have to install the shell-compat feature to provide felix gogo
>> commands.
>>
>> Regards
>> JB
>>
>> On 11/11/2017 05:58 PM, Francois Papon wrote:
>>> Hi,
>>>
>>> I've got an error when installing activemq feature link to the version
>>> of felix gogo command :
>>>
>>> karaf@root()> feature:install activemq
>>> Error executing command: Unable to resolve root: missing requirement
>>> [root] osgi.identity; osgi.identity=activemq; type=karaf.feature;
>>> version="[5.15.2,5.15.2]";
>>> filter:="(&(osgi.identity=activemq)(type=karaf.feature)(version>=5.15.2)(version<=5.15.2))"
>>>
>>> [caused by: Unable to resolve activemq/5.15.2: missing requirement
>>> [activemq/5.15.2] osgi.identity; osgi.identity=activemq-karaf;
>>> type=osgi.bundle; version="[5.15.2,5.15.2]"; resolution:=mandatory
>>> [caused by: Unable to resolve activemq-karaf/5.15.2: missing requirement
>>> [activemq-karaf/5.15.2] osgi.wiring.package;
>>> filter:="(&(osgi.wiring.package=org.apache.felix.gogo.commands)(version>=0.16.0)(!(version>=1.0.0)))"]]
>>>
>>>
>>>
>>
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com