Camel 3.2.0 install on Karaf 4.2.8

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Camel 3.2.0 install on Karaf 4.2.8

Oleg Cohen
Greetings,

Not sure if anybody ran into this issue.

I am starting with a brand new instance of Karaf 4.2.8

I added camel and camel-extras repos

feature:repo-add camel
feature:repo-add camel-extras

karaf@root()> feature:repo-list | grep camel
camel-3.2.0                               │ mvn:org.apache.camel.karaf/apache-camel/RELEASE/xml/features
camel-extra-2.24.3                        │ mvn:org.apache-extras.camel-extra.karaf/camel-extra/RELEASE/xml/features
camel-2.24.3                              │ mvn:org.apache.camel.karaf/apache-camel/2.24.3/xml/features

When I try to install camel-core I get the following exception:

karaf@root()> feature:install camel
Error executing command: Error:
Error downloading mvn:org.apache.camel/camel-commands-core/3.2.0
karaf@root()> feature:install camel-core
Error executing command: Error:
Error downloading mvn:org.apache.camel/camel-commands-core/3.2.0

Seems org.apache.camel/camel-commands-core/3.2.0 is missing. 

Would appreciate suggestions!

Thank you,
Oleg


--
Oleg Cohen  |  Principal  |  A S S U R E B R I D G E
Office: +1 617 564 0737  |  Mobile: +1 617 455 7927  |  Fax: +1 888 409 6995
Email: [hidden email]  
|  www.assurebridge.com
Reply | Threaded
Open this post in threaded view
|

Re: Camel 3.2.0 install on Karaf 4.2.8

Freeman-2
Hi,

This is a known issue caused by karaf related stuff in camel being moved to camel-karaf sub-project and this already get fixed at camel.

Please take a look at the discussion here to get the idea how to workaround this.

Freeman

On Fri, Apr 10, 2020 at 4:40 PM Oleg Cohen <[hidden email]> wrote:
Greetings,

Not sure if anybody ran into this issue.

I am starting with a brand new instance of Karaf 4.2.8

I added camel and camel-extras repos

feature:repo-add camel
feature:repo-add camel-extras

karaf@root()> feature:repo-list | grep camel
camel-3.2.0                               │ mvn:org.apache.camel.karaf/apache-camel/RELEASE/xml/features
camel-extra-2.24.3                        │ mvn:org.apache-extras.camel-extra.karaf/camel-extra/RELEASE/xml/features
camel-2.24.3                              │ mvn:org.apache.camel.karaf/apache-camel/2.24.3/xml/features

When I try to install camel-core I get the following exception:

karaf@root()> feature:install camel
Error executing command: Error:
Error downloading mvn:org.apache.camel/camel-commands-core/3.2.0
karaf@root()> feature:install camel-core
Error executing command: Error:
Error downloading mvn:org.apache.camel/camel-commands-core/3.2.0

Seems org.apache.camel/camel-commands-core/3.2.0 is missing. 

Would appreciate suggestions!

Thank you,
Oleg


--
Oleg Cohen  |  Principal  |  A S S U R E B R I D G E
Office: +1 617 564 0737  |  Mobile: +1 617 455 7927  |  Fax: +1 888 409 6995
Email: [hidden email]  
|  www.assurebridge.com
Reply | Threaded
Open this post in threaded view
|

Re: Camel 3.2.0 install on Karaf 4.2.8

Oleg Cohen
Thank you, Freeman!

I missed this one. Looks promising.

Best,
Oleg 

Sent from my iPhone

On Apr 10, 2020, at 5:00 PM, Freeman Fang <[hidden email]> wrote:


Hi,

This is a known issue caused by karaf related stuff in camel being moved to camel-karaf sub-project and this already get fixed at camel.

Please take a look at the discussion here to get the idea how to workaround this.

Freeman

On Fri, Apr 10, 2020 at 4:40 PM Oleg Cohen <[hidden email]> wrote:
Greetings,

Not sure if anybody ran into this issue.

I am starting with a brand new instance of Karaf 4.2.8

I added camel and camel-extras repos

feature:repo-add camel
feature:repo-add camel-extras

karaf@root()> feature:repo-list | grep camel
camel-3.2.0                               │ mvn:org.apache.camel.karaf/apache-camel/RELEASE/xml/features
camel-extra-2.24.3                        │ mvn:org.apache-extras.camel-extra.karaf/camel-extra/RELEASE/xml/features
camel-2.24.3                              │ mvn:org.apache.camel.karaf/apache-camel/2.24.3/xml/features

When I try to install camel-core I get the following exception:

karaf@root()> feature:install camel
Error executing command: Error:
Error downloading mvn:org.apache.camel/camel-commands-core/3.2.0
karaf@root()> feature:install camel-core
Error executing command: Error:
Error downloading mvn:org.apache.camel/camel-commands-core/3.2.0

Seems org.apache.camel/camel-commands-core/3.2.0 is missing. 

Would appreciate suggestions!

Thank you,
Oleg


--
Oleg Cohen  |  Principal  |  A S S U R E B R I D G E
Office: +1 617 564 0737  |  Mobile: +1 617 455 7927  |  Fax: +1 888 409 6995
Email: [hidden email]  
|  www.assurebridge.com
Reply | Threaded
Open this post in threaded view
|

Re: Camel 3.2.0 install on Karaf 4.2.8

jbonofre
In reply to this post by Oleg Cohen
Hi Oleg,

It’s a known issue in Camel feature.

The artifacts are located in org.apache.camel.karaf now (not directly in org.apache.camel).

I have a workaround (waiting new Camel feature) in Karaf: you have to add the following etc/org.apache.karaf.features.xml:

  <bundleReplacements>
       <bundle mode="maven" originalUri="mvn:org.apache.camel/camel-commands-core/3.2.0" replacement="mvn:org.apache.camel.karaf/camel-commands-core/3.2.0"/>
   </bundleReplacements>

Regards
JB

Le 10 avr. 2020 à 22:39, Oleg Cohen <[hidden email]> a écrit :

Greetings,

Not sure if anybody ran into this issue.

I am starting with a brand new instance of Karaf 4.2.8

I added camel and camel-extras repos

feature:repo-add camel
feature:repo-add camel-extras

karaf@root()> feature:repo-list | grep camel
camel-3.2.0                               │ mvn:org.apache.camel.karaf/apache-camel/RELEASE/xml/features
camel-extra-2.24.3                        │ mvn:org.apache-extras.camel-extra.karaf/camel-extra/RELEASE/xml/features
camel-2.24.3                              │ mvn:org.apache.camel.karaf/apache-camel/2.24.3/xml/features

When I try to install camel-core I get the following exception:

karaf@root()> feature:install camel
Error executing command: Error:
Error downloading mvn:org.apache.camel/camel-commands-core/3.2.0
karaf@root()> feature:install camel-core
Error executing command: Error:
Error downloading mvn:org.apache.camel/camel-commands-core/3.2.0

Seems org.apache.camel/camel-commands-core/3.2.0 is missing. 

Would appreciate suggestions!

Thank you,
Oleg


--
Oleg Cohen  |  Principal  |  A S S U R E B R I D G E
Office: +1 617 564 0737  |  Mobile: +1 617 455 7927  |  Fax: +1 888 409 6995
Email: [hidden email]  
|  www.assurebridge.com

Reply | Threaded
Open this post in threaded view
|

Re: Camel 3.2.0 install on Karaf 4.2.8

Oleg Cohen
Hi JB,

Thank you, it did the trick!

Best,
Oleg

Sent from my iPhone

On Apr 11, 2020, at 1:18 AM, Jean-Baptiste Onofre <[hidden email]> wrote:

Hi Oleg,

It’s a known issue in Camel feature.

The artifacts are located in org.apache.camel.karaf now (not directly in org.apache.camel).

I have a workaround (waiting new Camel feature) in Karaf: you have to add the following etc/org.apache.karaf.features.xml:

  <bundleReplacements>
       <bundle mode="maven" originalUri="mvn:org.apache.camel/camel-commands-core/3.2.0" replacement="mvn:org.apache.camel.karaf/camel-commands-core/3.2.0"/>
   </bundleReplacements>

Regards
JB

Le 10 avr. 2020 à 22:39, Oleg Cohen <[hidden email]> a écrit :

Greetings,

Not sure if anybody ran into this issue.

I am starting with a brand new instance of Karaf 4.2.8

I added camel and camel-extras repos

feature:repo-add camel
feature:repo-add camel-extras

karaf@root()> feature:repo-list | grep camel
camel-3.2.0                               │ mvn:org.apache.camel.karaf/apache-camel/RELEASE/xml/features
camel-extra-2.24.3                        │ mvn:org.apache-extras.camel-extra.karaf/camel-extra/RELEASE/xml/features
camel-2.24.3                              │ mvn:org.apache.camel.karaf/apache-camel/2.24.3/xml/features

When I try to install camel-core I get the following exception:

karaf@root()> feature:install camel
Error executing command: Error:
Error downloading mvn:org.apache.camel/camel-commands-core/3.2.0
karaf@root()> feature:install camel-core
Error executing command: Error:
Error downloading mvn:org.apache.camel/camel-commands-core/3.2.0

Seems org.apache.camel/camel-commands-core/3.2.0 is missing. 

Would appreciate suggestions!

Thank you,
Oleg


--
Oleg Cohen  |  Principal  |  A S S U R E B R I D G E
Office: +1 617 564 0737  |  Mobile: +1 617 455 7927  |  Fax: +1 888 409 6995
Email: [hidden email]  
|  www.assurebridge.com