Quantcast

Deployment of openejb in karaf 3

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Deployment of openejb in karaf 3

sahlex
Hello everyone.

I've just tried to install openejb feature in karaf 3 by doing

> feature:repo-add openejb 4.5.2
 (I've also tried with 4.5.1 and LATEST version)

That worked so far but when actually installing openejb feature by doing
> feature:install openejb-core

karaf installs and starts some bundles and then fails at start of geronimo-jaxb_2.2_spec with:
Exception caught while executing command java.lang.Exception: Could not start bundle bundle mvn:org.apache.geronimo.specs/geronimo-jaxb_2.2_spec/1.0.1 in feature(s) javaee-api-6.0-4: Unresolved constraint in bundle org.apache.geronimo.specs.geronimo-jaxb_2.2_spec [339]: Unable to resolve 339.0: missing requirement [339.0] osgi.wiring.package; (&(osgi.wiring.package=javax.xml.namespace)(version>=1.0.0))

What's missing here?

Best regards,
Alexander
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Deployment of openejb in karaf 3

sahlex
Loading...