Error installing openjpa/3.0.0 in karaf 4.2.7

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Error installing openjpa/3.0.0 in karaf 4.2.7

tvogel
I am unable to install openjpa/3.0.0 in a clean distribution of karaf 4.2.7.  

Similar / Same error as in this post
http://karaf.922171.n3.nabble.com/Openjpa-feature-resolution-error-on-Karaf-4-2-2-tp4054700.html
<http://karaf.922171.n3.nabble.com/Openjpa-feature-resolution-error-on-Karaf-4-2-2-tp4054700.html>  

Is there a solution to this error?
Thanks,
Timothy

my full session:
karaf@root(bundle)> feature:install -v jdbc jndi transaction jpa openjpa
Adding features:
jpa/[2.7.2,2.7.2],openjpa/[3.0.0,3.0.0],jndi/[4.2.7,4.2.7],transaction/[2.0.0,2.0.0],jdbc/[4.2.7,4.2.7]
Changes to perform:
  Region: root
    Bundles to install:
      mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
     
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.3_1
      mvn:org.ops4j.pax.jdbc/pax-jdbc/1.4.0
      mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.4.0
      mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.4.0
      mvn:org.osgi/org.osgi.service.jdbc/1.0.0
Installing bundles:
  mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
 
mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.3_1
  mvn:org.ops4j.pax.jdbc/pax-jdbc/1.4.0
  mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.4.0
  mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.4.0
  mvn:org.osgi/org.osgi.service.jdbc/1.0.0
Starting bundles:
  org.apache.geronimo.specs.geronimo-jta_1.1_spec/1.1.1
  org.osgi.service.jdbc/1.0.0.201505202023
  org.ops4j.pax.jdbc.pool.common/1.4.0
  org.ops4j.pax.jdbc/1.4.0
  org.apache.servicemix.bundles.jasypt/1.9.3.1
  org.ops4j.pax.jdbc.config/1.4.0
Done.
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root:
missing requirement [root] osgi.identity; osgi.identity=openjpa;
type=karaf.feature; version="[3.0.0,3.0.0]";
filter:="(&(osgi.identity=openjpa)(type=karaf.feature)(version>=3.0.0)(version<=3.0.0))"
[caused by: Unable to resolve openjpa/3.0.0: missing requirement
[openjpa/3.0.0] osgi.identity; osgi.identity=org.apache.openjpa;
type=osgi.bundle; version="[3.0.0,3.0.0]"; resolution:=mandatory [caused by:
Unable to resolve org.apache.openjpa/3.0.0: missing requirement
[org.apache.openjpa/3.0.0] osgi.wiring.package;
filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"]]
        at
org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
        at
org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
        at
org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
        at
org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
        at
org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
        at
org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
        at
org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
        at
org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
        at java.lang.Thread.run(Thread.java:748)
Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to
resolve openjpa/3.0.0: missing requirement [openjpa/3.0.0] osgi.identity;
osgi.identity=org.apache.openjpa; type=osgi.bundle; version="[3.0.0,3.0.0]";
resolution:=mandatory [caused by: Unable to resolve
org.apache.openjpa/3.0.0: missing requirement [org.apache.openjpa/3.0.0]
osgi.wiring.package;
filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"]
        at
org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
        ... 12 more
Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to
resolve org.apache.openjpa/3.0.0: missing requirement
[org.apache.openjpa/3.0.0] osgi.wiring.package;
filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"
        at
org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
        ... 13 more
Error executing command: Unable to resolve root: missing requirement [root]
osgi.identity; osgi.identity=openjpa; type=karaf.feature;
version="[3.0.0,3.0.0]";
filter:="(&(osgi.identity=openjpa)(type=karaf.feature)(version>=3.0.0)(version<=3.0.0))"
[caused by: Unable to resolve openjpa/3.0.0: missing requirement
[openjpa/3.0.0] osgi.identity; osgi.identity=org.apache.openjpa;
type=osgi.bundle; version="[3.0.0,3.0.0]"; resolution:=mandatory [caused by:
Unable to resolve org.apache.openjpa/3.0.0: missing requirement
[org.apache.openjpa/3.0.0] osgi.wiring.package;
filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"]]
karaf@root(bundle)>



--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
Reply | Threaded
Open this post in threaded view
|

Re: Error installing openjpa/3.0.0 in karaf 4.2.7

jbonofre
Hi,

the features might be updated.

Let me try to reproduce (the openjpa feature should be covered by itests
though).

I keep you posted.

Regards
JB

On 17/11/2019 12:49, tvogel wrote:

> I am unable to install openjpa/3.0.0 in a clean distribution of karaf 4.2.7.  
>
> Similar / Same error as in this post
> http://karaf.922171.n3.nabble.com/Openjpa-feature-resolution-error-on-Karaf-4-2-2-tp4054700.html
> <http://karaf.922171.n3.nabble.com/Openjpa-feature-resolution-error-on-Karaf-4-2-2-tp4054700.html>  
>
> Is there a solution to this error?
> Thanks,
> Timothy
>
> my full session:
> karaf@root(bundle)> feature:install -v jdbc jndi transaction jpa openjpa
> Adding features:
> jpa/[2.7.2,2.7.2],openjpa/[3.0.0,3.0.0],jndi/[4.2.7,4.2.7],transaction/[2.0.0,2.0.0],jdbc/[4.2.7,4.2.7]
> Changes to perform:
>   Region: root
>     Bundles to install:
>       mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
>      
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.3_1
>       mvn:org.ops4j.pax.jdbc/pax-jdbc/1.4.0
>       mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.4.0
>       mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.4.0
>       mvn:org.osgi/org.osgi.service.jdbc/1.0.0
> Installing bundles:
>   mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
>  
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.3_1
>   mvn:org.ops4j.pax.jdbc/pax-jdbc/1.4.0
>   mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.4.0
>   mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.4.0
>   mvn:org.osgi/org.osgi.service.jdbc/1.0.0
> Starting bundles:
>   org.apache.geronimo.specs.geronimo-jta_1.1_spec/1.1.1
>   org.osgi.service.jdbc/1.0.0.201505202023
>   org.ops4j.pax.jdbc.pool.common/1.4.0
>   org.ops4j.pax.jdbc/1.4.0
>   org.apache.servicemix.bundles.jasypt/1.9.3.1
>   org.ops4j.pax.jdbc.config/1.4.0
> Done.
> org.apache.felix.resolver.reason.ReasonException: Unable to resolve root:
> missing requirement [root] osgi.identity; osgi.identity=openjpa;
> type=karaf.feature; version="[3.0.0,3.0.0]";
> filter:="(&(osgi.identity=openjpa)(type=karaf.feature)(version>=3.0.0)(version<=3.0.0))"
> [caused by: Unable to resolve openjpa/3.0.0: missing requirement
> [openjpa/3.0.0] osgi.identity; osgi.identity=org.apache.openjpa;
> type=osgi.bundle; version="[3.0.0,3.0.0]"; resolution:=mandatory [caused by:
> Unable to resolve org.apache.openjpa/3.0.0: missing requirement
> [org.apache.openjpa/3.0.0] osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"]]
>         at
> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
>         at
> org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
>         at
> org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
>         at
> org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
>         at
> org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
>         at
> org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
>         at
> org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
>         at
> org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
>         at java.util.concurrent.FutureTask.run(FutureTask.java:266)
>         at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
>         at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
>         at java.lang.Thread.run(Thread.java:748)
> Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to
> resolve openjpa/3.0.0: missing requirement [openjpa/3.0.0] osgi.identity;
> osgi.identity=org.apache.openjpa; type=osgi.bundle; version="[3.0.0,3.0.0]";
> resolution:=mandatory [caused by: Unable to resolve
> org.apache.openjpa/3.0.0: missing requirement [org.apache.openjpa/3.0.0]
> osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"]
>         at
> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
>         ... 12 more
> Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to
> resolve org.apache.openjpa/3.0.0: missing requirement
> [org.apache.openjpa/3.0.0] osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"
>         at
> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
>         ... 13 more
> Error executing command: Unable to resolve root: missing requirement [root]
> osgi.identity; osgi.identity=openjpa; type=karaf.feature;
> version="[3.0.0,3.0.0]";
> filter:="(&(osgi.identity=openjpa)(type=karaf.feature)(version>=3.0.0)(version<=3.0.0))"
> [caused by: Unable to resolve openjpa/3.0.0: missing requirement
> [openjpa/3.0.0] osgi.identity; osgi.identity=org.apache.openjpa;
> type=osgi.bundle; version="[3.0.0,3.0.0]"; resolution:=mandatory [caused by:
> Unable to resolve org.apache.openjpa/3.0.0: missing requirement
> [org.apache.openjpa/3.0.0] osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"]]
> karaf@root(bundle)>
>
>
>
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

Re: Error installing openjpa/3.0.0 in karaf 4.2.7

jbonofre
In reply to this post by tvogel
Hi,

I confirm the issue (related to XBean update/import range).

I created https://issues.apache.org/jira/browse/KARAF-6521 about that.

It will be fixed in Karaf 4.2.8.

Sorry for the inconvenience.

Regards
JB

On 17/11/2019 12:49, tvogel wrote:

> I am unable to install openjpa/3.0.0 in a clean distribution of karaf 4.2.7.  
>
> Similar / Same error as in this post
> http://karaf.922171.n3.nabble.com/Openjpa-feature-resolution-error-on-Karaf-4-2-2-tp4054700.html
> <http://karaf.922171.n3.nabble.com/Openjpa-feature-resolution-error-on-Karaf-4-2-2-tp4054700.html>  
>
> Is there a solution to this error?
> Thanks,
> Timothy
>
> my full session:
> karaf@root(bundle)> feature:install -v jdbc jndi transaction jpa openjpa
> Adding features:
> jpa/[2.7.2,2.7.2],openjpa/[3.0.0,3.0.0],jndi/[4.2.7,4.2.7],transaction/[2.0.0,2.0.0],jdbc/[4.2.7,4.2.7]
> Changes to perform:
>   Region: root
>     Bundles to install:
>       mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
>      
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.3_1
>       mvn:org.ops4j.pax.jdbc/pax-jdbc/1.4.0
>       mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.4.0
>       mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.4.0
>       mvn:org.osgi/org.osgi.service.jdbc/1.0.0
> Installing bundles:
>   mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
>  
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.3_1
>   mvn:org.ops4j.pax.jdbc/pax-jdbc/1.4.0
>   mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.4.0
>   mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.4.0
>   mvn:org.osgi/org.osgi.service.jdbc/1.0.0
> Starting bundles:
>   org.apache.geronimo.specs.geronimo-jta_1.1_spec/1.1.1
>   org.osgi.service.jdbc/1.0.0.201505202023
>   org.ops4j.pax.jdbc.pool.common/1.4.0
>   org.ops4j.pax.jdbc/1.4.0
>   org.apache.servicemix.bundles.jasypt/1.9.3.1
>   org.ops4j.pax.jdbc.config/1.4.0
> Done.
> org.apache.felix.resolver.reason.ReasonException: Unable to resolve root:
> missing requirement [root] osgi.identity; osgi.identity=openjpa;
> type=karaf.feature; version="[3.0.0,3.0.0]";
> filter:="(&(osgi.identity=openjpa)(type=karaf.feature)(version>=3.0.0)(version<=3.0.0))"
> [caused by: Unable to resolve openjpa/3.0.0: missing requirement
> [openjpa/3.0.0] osgi.identity; osgi.identity=org.apache.openjpa;
> type=osgi.bundle; version="[3.0.0,3.0.0]"; resolution:=mandatory [caused by:
> Unable to resolve org.apache.openjpa/3.0.0: missing requirement
> [org.apache.openjpa/3.0.0] osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"]]
>         at
> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
>         at
> org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
>         at
> org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
>         at
> org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
>         at
> org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
>         at
> org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
>         at
> org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
>         at
> org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
>         at java.util.concurrent.FutureTask.run(FutureTask.java:266)
>         at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
>         at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
>         at java.lang.Thread.run(Thread.java:748)
> Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to
> resolve openjpa/3.0.0: missing requirement [openjpa/3.0.0] osgi.identity;
> osgi.identity=org.apache.openjpa; type=osgi.bundle; version="[3.0.0,3.0.0]";
> resolution:=mandatory [caused by: Unable to resolve
> org.apache.openjpa/3.0.0: missing requirement [org.apache.openjpa/3.0.0]
> osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"]
>         at
> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
>         ... 12 more
> Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to
> resolve org.apache.openjpa/3.0.0: missing requirement
> [org.apache.openjpa/3.0.0] osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"
>         at
> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
>         ... 13 more
> Error executing command: Unable to resolve root: missing requirement [root]
> osgi.identity; osgi.identity=openjpa; type=karaf.feature;
> version="[3.0.0,3.0.0]";
> filter:="(&(osgi.identity=openjpa)(type=karaf.feature)(version>=3.0.0)(version<=3.0.0))"
> [caused by: Unable to resolve openjpa/3.0.0: missing requirement
> [openjpa/3.0.0] osgi.identity; osgi.identity=org.apache.openjpa;
> type=osgi.bundle; version="[3.0.0,3.0.0]"; resolution:=mandatory [caused by:
> Unable to resolve org.apache.openjpa/3.0.0: missing requirement
> [org.apache.openjpa/3.0.0] osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"]]
> karaf@root(bundle)>
>
>
>
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

Re: Error installing openjpa/3.0.0 in karaf 4.2.7

tvogel
Thanks for the quick response and confirmation.  I'll try 4.2.6 in the
meantime.

Timothy



--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
Reply | Threaded
Open this post in threaded view
|

Re: Error installing openjpa/3.0.0 in karaf 4.2.7

jbonofre
Hi Timothy,

unfortunately, I think it will fail with several Karaf version.

I can provide a patch to you.

Anyway I plan 4.2.8 soon, so,  if you can wait a bit, it would be even
better.

Regards
JB

On 18/11/2019 13:28, tvogel wrote:

> Thanks for the quick response and confirmation.  I'll try 4.2.6 in the
> meantime.
>
> Timothy
>
>
>
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

Re: Error installing openjpa/3.0.0 in karaf 4.2.7

jbonofre
In reply to this post by tvogel
Hi,

OK, I remember now ;)

You should not use the openjpa feature provided by OpenJPA.

Instead, we create openjpa3 feature in Karaf that fix the asm/xbean issue.

If you do:

feature:install openjpa3

it should work smoothly (just tested it without problem).

Regards
JB

On 17/11/2019 12:49, tvogel wrote:

> I am unable to install openjpa/3.0.0 in a clean distribution of karaf 4.2.7.  
>
> Similar / Same error as in this post
> http://karaf.922171.n3.nabble.com/Openjpa-feature-resolution-error-on-Karaf-4-2-2-tp4054700.html
> <http://karaf.922171.n3.nabble.com/Openjpa-feature-resolution-error-on-Karaf-4-2-2-tp4054700.html>  
>
> Is there a solution to this error?
> Thanks,
> Timothy
>
> my full session:
> karaf@root(bundle)> feature:install -v jdbc jndi transaction jpa openjpa
> Adding features:
> jpa/[2.7.2,2.7.2],openjpa/[3.0.0,3.0.0],jndi/[4.2.7,4.2.7],transaction/[2.0.0,2.0.0],jdbc/[4.2.7,4.2.7]
> Changes to perform:
>   Region: root
>     Bundles to install:
>       mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
>      
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.3_1
>       mvn:org.ops4j.pax.jdbc/pax-jdbc/1.4.0
>       mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.4.0
>       mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.4.0
>       mvn:org.osgi/org.osgi.service.jdbc/1.0.0
> Installing bundles:
>   mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
>  
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.3_1
>   mvn:org.ops4j.pax.jdbc/pax-jdbc/1.4.0
>   mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.4.0
>   mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.4.0
>   mvn:org.osgi/org.osgi.service.jdbc/1.0.0
> Starting bundles:
>   org.apache.geronimo.specs.geronimo-jta_1.1_spec/1.1.1
>   org.osgi.service.jdbc/1.0.0.201505202023
>   org.ops4j.pax.jdbc.pool.common/1.4.0
>   org.ops4j.pax.jdbc/1.4.0
>   org.apache.servicemix.bundles.jasypt/1.9.3.1
>   org.ops4j.pax.jdbc.config/1.4.0
> Done.
> org.apache.felix.resolver.reason.ReasonException: Unable to resolve root:
> missing requirement [root] osgi.identity; osgi.identity=openjpa;
> type=karaf.feature; version="[3.0.0,3.0.0]";
> filter:="(&(osgi.identity=openjpa)(type=karaf.feature)(version>=3.0.0)(version<=3.0.0))"
> [caused by: Unable to resolve openjpa/3.0.0: missing requirement
> [openjpa/3.0.0] osgi.identity; osgi.identity=org.apache.openjpa;
> type=osgi.bundle; version="[3.0.0,3.0.0]"; resolution:=mandatory [caused by:
> Unable to resolve org.apache.openjpa/3.0.0: missing requirement
> [org.apache.openjpa/3.0.0] osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"]]
>         at
> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
>         at
> org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
>         at
> org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
>         at
> org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
>         at
> org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
>         at
> org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
>         at
> org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
>         at
> org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
>         at java.util.concurrent.FutureTask.run(FutureTask.java:266)
>         at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
>         at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
>         at java.lang.Thread.run(Thread.java:748)
> Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to
> resolve openjpa/3.0.0: missing requirement [openjpa/3.0.0] osgi.identity;
> osgi.identity=org.apache.openjpa; type=osgi.bundle; version="[3.0.0,3.0.0]";
> resolution:=mandatory [caused by: Unable to resolve
> org.apache.openjpa/3.0.0: missing requirement [org.apache.openjpa/3.0.0]
> osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"]
>         at
> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
>         ... 12 more
> Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to
> resolve org.apache.openjpa/3.0.0: missing requirement
> [org.apache.openjpa/3.0.0] osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"
>         at
> org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
>         ... 13 more
> Error executing command: Unable to resolve root: missing requirement [root]
> osgi.identity; osgi.identity=openjpa; type=karaf.feature;
> version="[3.0.0,3.0.0]";
> filter:="(&(osgi.identity=openjpa)(type=karaf.feature)(version>=3.0.0)(version<=3.0.0))"
> [caused by: Unable to resolve openjpa/3.0.0: missing requirement
> [openjpa/3.0.0] osgi.identity; osgi.identity=org.apache.openjpa;
> type=osgi.bundle; version="[3.0.0,3.0.0]"; resolution:=mandatory [caused by:
> Unable to resolve org.apache.openjpa/3.0.0: missing requirement
> [org.apache.openjpa/3.0.0] osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.apache.xbean.asm6)(version>=6.1.0)(!(version>=7.0.0)))"]]
> karaf@root(bundle)>
>
>
>
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

Re: Error installing openjpa/3.0.0 in karaf 4.2.7

tvogel
JB,
  The feature installed fine using openjpa3.  I'm in the process of testing
my application to ensure it still functions.

Thanks for the assistance!
Timothy



--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
Reply | Threaded
Open this post in threaded view
|

Re: Error installing openjpa/3.0.0 in karaf 4.2.7

jbonofre
Hi Timothy

FYI, the jpa example (using openjpa3 feature) is executed/tests in the
itest. So, it works at least for the example.

Regards
JB

On 21/11/2019 04:22, tvogel wrote:

> JB,
>   The feature installed fine using openjpa3.  I'm in the process of testing
> my application to ensure it still functions.
>
> Thanks for the assistance!
> Timothy
>
>
>
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com