Quantcast

Fwd: Gemini Blueprint on Karaf 4.0.8

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Fwd: Gemini Blueprint on Karaf 4.0.8

Guillaume Nodet-2

As you can see, most bundles are refreshed because of shell.core being refreshed, which in turn is caused by the following:

    org.apache.karaf.shell.core/4.0.8 (Should be wired to: org.eclipse.gemini.blueprint.extender/2.0.0.RELEASE (through [org.apache.karaf.shell.console/4.0.8] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.osgi.service.blueprint)(version>=1.0.0)(!(version>=2.0.0)))"))

I suppose you have aries blueprint already installed, but the feature installer has decided that the shell.console bundle should be wired to the api from gemini instead.  
The shell.console bundle is not mandatory, but installed through the shell-compat feature which aims to support commands written for older versions of karaf.


2017-03-13 12:33 GMT+01:00 <[hidden email]>:
Hello! Here is the simulation:

Adding features: gemini-blueprint/[2.0.0.RELEASE,2.0.0.RELEASE]
Changes to perform:
  Region: root
    Bundles to install:
    mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.spring/4.0.8
      mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.aopalliance/1.0_6
      mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-aop/4.2.9.RELEASE_1
      mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-beans/4.2.9.RELEASE_1
      mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context/4.2.9.RELEASE_1
      mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-context-support/4.2.9.RELEASE_1
      mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-core/4.2.9.RELEASE_1
      mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.spring-expression/4.2.9.RELEASE_1
      mvn:org.eclipse.gemini.blueprint/gemini-blueprint-core/2.0.0.RELEASE
      mvn:org.eclipse.gemini.blueprint/gemini-blueprint-extender/2.0.0.RELEASE
      mvn:org.eclipse.gemini.blueprint/gemini-blueprint-io/2.0.0.RELEASE
  Bundles to refresh:
    org.apache.aries.blueprint.cm/1.0.9 (Should be wired to: org.eclipse.gemini.blueprint.extender/2.0.0.RELEASE (through [org.apache.aries.blueprint.cm/1.0.9] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.osgi.service.
blueprint)(version>=1.0.0)(!(version>=2.0.0)))"))
    org.apache.karaf.bundle.blueprintstate/4.0.8 (Wired to org.apache.karaf.bundle.core/4.0.8 which is being refreshed)
    org.apache.karaf.bundle.core/4.0.8 (Wired to org.apache.karaf.shell.core/4.0.8 which is being refreshed)
    org.apache.karaf.config.core/4.0.8 (Wired to org.apache.karaf.shell.core/4.0.8 which is being refreshed)
    org.apache.karaf.deployer.kar/4.0.8 (Wired to org.apache.karaf.kar.core/4.0.8 which is being refreshed)
    org.apache.karaf.diagnostic.core/4.0.8 (Wired to org.apache.karaf.shell.core/4.0.8 which is being refreshed)
    org.apache.karaf.features.command/4.0.8 (Wired to org.apache.karaf.shell.core/4.0.8 which is being refreshed)
    org.apache.karaf.instance.core/4.0.8 (Wired to org.apache.karaf.features.command/4.0.8 which is being refreshed)
    org.apache.karaf.jaas.blueprint.config/4.0.8 (Should be wired to: org.eclipse.gemini.blueprint.extender/2.0.0.RELEASE (through [org.apache.karaf.jaas.blueprint.config/4.0.8] osgi.wiring.package; filter:="(&(osgi.wiring.package
=org.osgi.service.blueprint)(version>=1.0.0)(!(version>=2.0.0)))"))
    org.apache.karaf.jaas.command/4.0.8 (Wired to org.apache.karaf.shell.core/4.0.8 which is being refreshed)
    org.apache.karaf.kar.core/4.0.8 (Wired to org.apache.karaf.features.command/4.0.8 which is being refreshed)
    org.apache.karaf.log.core/4.0.8 (Wired to org.apache.karaf.shell.core/4.0.8 which is being refreshed)
    org.apache.karaf.package.core/4.0.8 (Wired to org.apache.karaf.shell.core/4.0.8 which is being refreshed)
    org.apache.karaf.service.core/4.0.8 (Wired to org.apache.karaf.shell.core/4.0.8 which is being refreshed)
    org.apache.karaf.shell.commands/4.0.8 (Wired to org.apache.karaf.shell.core/4.0.8 which is being refreshed)
    org.apache.karaf.shell.console/4.0.8 (Wired to org.apache.karaf.shell.core/4.0.8 which is being refreshed)
    org.apache.karaf.shell.core/4.0.8 (Should be wired to: org.eclipse.gemini.blueprint.extender/2.0.0.RELEASE (through [org.apache.karaf.shell.console/4.0.8] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.osgi.service.b
lueprint)(version>=1.0.0)(!(version>=2.0.0)))"))
    org.apache.karaf.shell.ssh/4.0.8 (Wired to org.apache.karaf.shell.core/4.0.8 which is being refreshed)
    org.apache.karaf.system.core/4.0.8 (Wired to org.apache.karaf.shell.core/4.0.8 which is being refreshed)



<quote author='Guillaume Nodet-2'>
Can you run the installation using:
  feature:install --simulate --verbose gemini-blueprint
This should give more information about the exact reason why the bundles
are refreshed.

2017-03-12 21:12 GMT+01:00 Ygor Castor <[hidden email]>:

>  Since Spring DM is long dead and it's quite a buggy way to wire spring on
> a OSGi context i've decided to give Gemini a chance, since it's actively
> developed, first of all i've updated the feature to:
>
> http://pastebin.com/4sAzyxGg
>
> And it seems to work ok, but with one problem, when i install any feature
> the whole container goes awry, refreshing even core bundles, here is the
> log:
>
> http://pastebin.com/t8h2FTpt
>
> I've had the same problem before with Fragment bundles, i've created a
> Liquibase Extension fragment, and everytime that fragment got refreshed
> the
> whole container became a mess.
>
> Right now, to "solve" the problem i'm using a feature:install/uninstall -r
> , which disables feature bundles auto-refresh, and refreshing manualy
> using
> bundle:refresh, doing that there is no problem, and i'm able to use gemini
> and the fragments.
>
> I'm not sure this is a normal behavior, can anyone confirm?
>



--
------------------------
Guillaume Nodet

</quote>
Quoted from:
http://karaf.922171.n3.nabble.com/Gemini-Blueprint-on-Karaf-4-0-8-tp4049831p4049833.html


_____________________________________
Sent from http://karaf.922171.n3.nabble.com




--
------------------------
Guillaume Nodet




--
------------------------
Guillaume Nodet

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Fwd: Gemini Blueprint on Karaf 4.0.8

Castor
Ohh! I saw that but i tought the shell-compat bundle was mandatory, works like a charm now.

Thank you!
Loading...