Quantcast

Installing features error

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Installing features error

sana
I have modified the pom.xml of example cxf-jaxrs feature to add the jsonProvider dependencies
<dependency>
<groupId>org.codehaus.jackson</groupId>
<artifactId>jackson-jaxrs</artifactId>
<version>1.9.0</version>
</dependency>

It builds sucessfully but when I do feature:install examples-cxf-jaxrs, I get the below error

Error executing command: Can not resolve feature:
Unsatisfied requirement(s):
---------------------------
   package:(&(package=org.codehaus.jackson.jaxrs)(version>=1.9.0))
      Apache ServiceMix :: Features :: Examples :: CXF JAX-RS OSGI

I am new to OSGI and Servicemix. Please help figuring out the issue.
Loading...