K420: pax-jetty-http2 Crash and ResolutionException

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

K420: pax-jetty-http2 Crash and ResolutionException

maggu2810
Hi,

it seems that the feature "pax-jetty-http2" does not work.

Start with a fresh working copy:
===
rm -rf apache-karaf-4.2.0
tar xzf apache-karaf-4.2.0.tar.gz

Start Karaf:
===
apache-karaf-4.2.0/bin/karaf
===



Reproduce ResolutionException


Install feature:
===
feature:install pax-jetty-http2
===

Error message:
===
org.osgi.service.resolver.ResolutionException: Unable to resolve root:
missing requirement [root] osgi.identity;
osgi.identity=pax-jetty-http2; type=karaf.feature;
version="[7.0.0,7.0.0]";
filter:="(&(osgi.identity=pax-jetty-http2)(type=karaf.feature)(version>=7.0.0)(version<=7.0.0))"
[caused by: Unable to resolve pax-jetty-http2/7.0.0: missing
requirement [pax-jetty-http2/7.0.0] osgi.identity;
osgi.identity=org.eclipse.jetty.http2.common; type=osgi.bundle;
version="[9.4.6.v20170531,9.4.6.v20170531]"; resolution:=mandatory
[caused by: Unable to resolve
org.eclipse.jetty.http2.common/9.4.6.v20170531: missing requirement
[org.eclipse.jetty.http2.common/9.4.6.v20170531] osgi.wiring.package;
filter:="(&(osgi.wiring.package=org.eclipse.jetty.http2.hpack)(version>=9.4.6)(!(version>=9.4.7)))"
[caused by: Unable to resolve
org.eclipse.jetty.http2.hpack/9.4.6.v20170531: missing requirement
[org.eclipse.jetty.http2.hpack/9.4.6.v20170531] osgi.extender;
filter:="(osgi.extender=osgi.serviceloader.registrar)" [caused by:
Unable to resolve org.apache.aries.spifly.dynamic.bundle/1.0.10:
missing requirement [org.apache.aries.spifly.dynamic.bundle/1.0.10]
osgi.wiring.package;
filter:="(&(osgi.wiring.package=org.objectweb.asm)(version>=5.0.0)(!(version>=7.0.0)))"]]]]
at org.apache.felix.resolver.ResolutionError.toException(ResolutionError.java:42)
at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:391)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:377)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:331)
at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:248)
at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:388)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1025)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:964)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
Error executing command: Unable to resolve root: missing requirement
[root] osgi.identity; osgi.identity=pax-jetty-http2;
type=karaf.feature; version="[7.0.0,7.0.0]";
filter:="(&(osgi.identity=pax-jetty-http2)(type=karaf.feature)(version>=7.0.0)(version<=7.0.0))"
[caused by: Unable to resolve pax-jetty-http2/7.0.0: missing
requirement [pax-jetty-http2/7.0.0] osgi.identity;
osgi.identity=org.eclipse.jetty.http2.common; type=osgi.bundle;
version="[9.4.6.v20170531,9.4.6.v20170531]"; resolution:=mandatory
[caused by: Unable to resolve
org.eclipse.jetty.http2.common/9.4.6.v20170531: missing requirement
[org.eclipse.jetty.http2.common/9.4.6.v20170531] osgi.wiring.package;
filter:="(&(osgi.wiring.package=org.eclipse.jetty.http2.hpack)(version>=9.4.6)(!(version>=9.4.7)))"
[caused by: Unable to resolve
org.eclipse.jetty.http2.hpack/9.4.6.v20170531: missing requirement
[org.eclipse.jetty.http2.hpack/9.4.6.v20170531] osgi.extender;
filter:="(osgi.extender=osgi.serviceloader.registrar)" [caused by:
Unable to resolve org.apache.aries.spifly.dynamic.bundle/1.0.10:
missing requirement [org.apache.aries.spifly.dynamic.bundle/1.0.10]
osgi.wiring.package;
filter:="(&(osgi.wiring.package=org.objectweb.asm)(version>=5.0.0)(!(version>=7.0.0)))"]]]]
===



Reproduce Crash


Install whiteboard feature
===
karaf@root()> feature:install pax-http-whiteboard
                                                        ===

Install http2 feature
===
karaf@root()> feature:install pax-jetty-http2
===

Crash of Karaf (KAraf is terminated after the message):
===
java.lang.IllegalStateException: Invalid BundleContext.
at org.apache.felix.framework.BundleContextImpl.checkValidity(BundleContextImpl.java:511)
at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:146)
at org.eclipse.equinox.internal.region.BundleIdBasedRegion.installBundle0(BundleIdBasedRegion.java:117)
at org.eclipse.equinox.internal.region.BundleIdBasedRegion.installBundleAtLocation(BundleIdBasedRegion.java:97)
at org.apache.karaf.features.internal.service.BundleInstallSupportImpl.installBundle(BundleInstallSupportImpl.java:135)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.installBundle(FeaturesServiceImpl.java:1101)
at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:870)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1025)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:964)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
===
Reply | Threaded
Open this post in threaded view
|

Re: K420: pax-jetty-http2 Crash and ResolutionException

Guillaume Nodet-2
Could you please raise a JIRA issue ?
Fwiw, the problem is that this feature attaches a fragment to the system
bundle, so the framework has to be restarted, but for some reason, it fails
(it should work).

Guillaume

2018-04-11 11:15 GMT+02:00 Markus Rathgeb <[hidden email]>:

> Hi,
>
> it seems that the feature "pax-jetty-http2" does not work.
>
> Start with a fresh working copy:
> ===
> rm -rf apache-karaf-4.2.0
> tar xzf apache-karaf-4.2.0.tar.gz
>
> Start Karaf:
> ===
> apache-karaf-4.2.0/bin/karaf
> ===
>
>
>
> Reproduce ResolutionException
>
>
> Install feature:
> ===
> feature:install pax-jetty-http2
> ===
>
> Error message:
> ===
> org.osgi.service.resolver.ResolutionException: Unable to resolve root:
> missing requirement [root] osgi.identity;
> osgi.identity=pax-jetty-http2; type=karaf.feature;
> version="[7.0.0,7.0.0]";
> filter:="(&(osgi.identity=pax-jetty-http2)(type=karaf.
> feature)(version>=7.0.0)(version<=7.0.0))"
> [caused by: Unable to resolve pax-jetty-http2/7.0.0: missing
> requirement [pax-jetty-http2/7.0.0] osgi.identity;
> osgi.identity=org.eclipse.jetty.http2.common; type=osgi.bundle;
> version="[9.4.6.v20170531,9.4.6.v20170531]"; resolution:=mandatory
> [caused by: Unable to resolve
> org.eclipse.jetty.http2.common/9.4.6.v20170531: missing requirement
> [org.eclipse.jetty.http2.common/9.4.6.v20170531] osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.eclipse.jetty.
> http2.hpack)(version>=9.4.6)(!(version>=9.4.7)))"
> [caused by: Unable to resolve
> org.eclipse.jetty.http2.hpack/9.4.6.v20170531: missing requirement
> [org.eclipse.jetty.http2.hpack/9.4.6.v20170531] osgi.extender;
> filter:="(osgi.extender=osgi.serviceloader.registrar)" [caused by:
> Unable to resolve org.apache.aries.spifly.dynamic.bundle/1.0.10:
> missing requirement [org.apache.aries.spifly.dynamic.bundle/1.0.10]
> osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.objectweb.asm)(
> version>=5.0.0)(!(version>=7.0.0)))"]]]]
> at org.apache.felix.resolver.ResolutionError.toException(
> ResolutionError.java:42)
> at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:391)
> at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:377)
> at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:331)
> at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(
> SubsystemResolver.java:248)
> at org.apache.karaf.features.internal.service.Deployer.
> deploy(Deployer.java:388)
> at org.apache.karaf.features.internal.service.FeaturesServiceImpl.
> doProvision(FeaturesServiceImpl.java:1025)
> at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$
> doProvisionInThread$13(FeaturesServiceImpl.java:964)
> at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> at java.util.concurrent.ThreadPoolExecutor.runWorker(
> ThreadPoolExecutor.java:1149)
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(
> ThreadPoolExecutor.java:624)
> at java.lang.Thread.run(Thread.java:748)
> Error executing command: Unable to resolve root: missing requirement
> [root] osgi.identity; osgi.identity=pax-jetty-http2;
> type=karaf.feature; version="[7.0.0,7.0.0]";
> filter:="(&(osgi.identity=pax-jetty-http2)(type=karaf.
> feature)(version>=7.0.0)(version<=7.0.0))"
> [caused by: Unable to resolve pax-jetty-http2/7.0.0: missing
> requirement [pax-jetty-http2/7.0.0] osgi.identity;
> osgi.identity=org.eclipse.jetty.http2.common; type=osgi.bundle;
> version="[9.4.6.v20170531,9.4.6.v20170531]"; resolution:=mandatory
> [caused by: Unable to resolve
> org.eclipse.jetty.http2.common/9.4.6.v20170531: missing requirement
> [org.eclipse.jetty.http2.common/9.4.6.v20170531] osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.eclipse.jetty.
> http2.hpack)(version>=9.4.6)(!(version>=9.4.7)))"
> [caused by: Unable to resolve
> org.eclipse.jetty.http2.hpack/9.4.6.v20170531: missing requirement
> [org.eclipse.jetty.http2.hpack/9.4.6.v20170531] osgi.extender;
> filter:="(osgi.extender=osgi.serviceloader.registrar)" [caused by:
> Unable to resolve org.apache.aries.spifly.dynamic.bundle/1.0.10:
> missing requirement [org.apache.aries.spifly.dynamic.bundle/1.0.10]
> osgi.wiring.package;
> filter:="(&(osgi.wiring.package=org.objectweb.asm)(
> version>=5.0.0)(!(version>=7.0.0)))"]]]]
> ===
>
>
>
> Reproduce Crash
>
>
> Install whiteboard feature
> ===
> karaf@root()> feature:install pax-http-whiteboard
>                                                         ===
>
> Install http2 feature
> ===
> karaf@root()> feature:install pax-jetty-http2
> ===
>
> Crash of Karaf (KAraf is terminated after the message):
> ===
> java.lang.IllegalStateException: Invalid BundleContext.
> at org.apache.felix.framework.BundleContextImpl.checkValidity(
> BundleContextImpl.java:511)
> at org.apache.felix.framework.BundleContextImpl.installBundle(
> BundleContextImpl.java:146)
> at org.eclipse.equinox.internal.region.BundleIdBasedRegion.installBundle0(
> BundleIdBasedRegion.java:117)
> at org.eclipse.equinox.internal.region.BundleIdBasedRegion.
> installBundleAtLocation(BundleIdBasedRegion.java:97)
> at org.apache.karaf.features.internal.service.BundleInstallSupportImpl.
> installBundle(BundleInstallSupportImpl.java:135)
> at org.apache.karaf.features.internal.service.FeaturesServiceImpl.
> installBundle(FeaturesServiceImpl.java:1101)
> at org.apache.karaf.features.internal.service.Deployer.
> deploy(Deployer.java:870)
> at org.apache.karaf.features.internal.service.FeaturesServiceImpl.
> doProvision(FeaturesServiceImpl.java:1025)
> at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$
> doProvisionInThread$13(FeaturesServiceImpl.java:964)
> at java.util.concurrent.FutureTask.run(FutureTask.java:266)
> at java.util.concurrent.ThreadPoolExecutor.runWorker(
> ThreadPoolExecutor.java:1149)
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(
> ThreadPoolExecutor.java:624)
> at java.lang.Thread.run(Thread.java:748)
> ===
>



--
------------------------
Guillaume Nodet
Reply | Threaded
Open this post in threaded view
|

Re: K420: pax-jetty-http2 Crash and ResolutionException

maggu2810
Thank you for your response.
I will raise a JIRA tomorrow.
Reply | Threaded
Open this post in threaded view
|

Re: K420: pax-jetty-http2 Crash and ResolutionException

maggu2810
JIRA: https://issues.apache.org/jira/browse/KARAF-5701

2018-04-12 17:12 GMT+02:00 Markus Rathgeb <[hidden email]>:
> Thank you for your response.
> I will raise a JIRA tomorrow.