Karaf 3.0.0-SNAPSHOT not works

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Karaf 3.0.0-SNAPSHOT not works

Guofeng Zhang-2

Hi,

 

I update Karaf 3.0.0 SHAPSHOT today and got some error, Kara not stable now.

(1)

2012-01-17 18:17:20,928 | ERROR | .features.repos) | configadmin                      | ?                                   ? | 5 - org.apache.felix.configadmin - 1.2.8 | [org.osgi.service.cm.ManagedService, id=56, bundle=21]: Unexpected problem updating null

java.lang.NullPointerException

         at org.apache.karaf.features.command.FeatureFinder.updated(FeatureFinder.java:46)

         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[:1.6.0_24]

         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)[:1.6.0_24]

         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)[:1.6.0_24]

         at java.lang.reflect.Method.invoke(Method.java:597)[:1.6.0_24]

         at org.apache.aries.proxy.impl.ProxyHandler$1.invoke(ProxyHandler.java:54)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]

         at org.apache.aries.proxy.impl.ProxyHandler.invoke(ProxyHandler.java:119)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]

         at $Proxy19.updated(Unknown Source)[5:org.apache.felix.configadmin:1.2.8]

         at org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.run(ConfigurationManager.java:1160)[5:org.apache.felix.configadmin:1.2.8]

         at org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:104)[5:org.apache.felix.configadmin:1.2.8]

         at java.lang.Thread.run(Thread.java:662)[:1.6.0_24]

(2)

2012-01-17 18:18:49,678 | ERROR | Thread-3         | FeaturesServiceImpl              | s.internal.FeaturesServiceImpl$1 1029 | 15 - org.apache.karaf.features.core - 3.0.0.SNAPSHOT | Error installing boot features

java.lang.Exception: Could not start bundle mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))

         at org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:407)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]

         at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:362)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]

         at org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:1027)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]

Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing requirement [27.0] osgi.wiring.package; (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))

         at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)[org.apache.felix.framework-4.0.2.jar:]

         at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)[org.apache.felix.framework-4.0.2.jar:]

         at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)[org.apache.felix.framework-4.0.2.jar:]

         at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:931)[org.apache.felix.framework-4.0.2.jar:]

         at org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:404)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]

         ... 2 more

I think this might be org.eclipse.equinox/region/1.0.0.v20110506 missed in startup.properties.

 

(3) when I type TAB on the console, there is error in the log:

2012-01-17 18:19:33,474 | INFO  | l Console Thread | ServiceRecipe                    | viceRecipe$TriggerServiceFactory  497 | 13 - org.apache.aries.blueprint.core - 0.4.1.SNAPSHOT | Unable to create a proxy object for the service shell-104 defined in bundle org.apache.karaf.shell.config at version 3.0.0.SNAPSHOT with id 26. Returning the original object instead.

org.apache.aries.proxy.UnableToProxyException: The class org.apache.karaf.shell.console.commands.BlueprintCommand is not an interface and therefore a proxy cannot be generated.

         at org.apache.aries.proxy.impl.JdkProxyManager.getInterfaces(JdkProxyManager.java:43)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]

         at org.apache.aries.proxy.impl.JdkProxyManager.createNewProxy(JdkProxyManager.java:36)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]

…..

 

I attached the log.

 

Windows XP SP3, jdk1.6.0_24

 

Thanks

 

Guofeng

 


karaf.log (459K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Karaf 3.0.0-SNAPSHOT not works

jbonofre
Hi,

We are in the stabilization phase and feature freeze.

A new snapshot will be deployed soon which fix the issue.

Regards
JB

On 01/17/2012 11:25 AM, Guofeng Zhang wrote:

> Hi,
>
> I update Karaf 3.0.0 SHAPSHOT today and got some error, Kara not stable now.
>
> (1)
>
> 2012-01-17 18:17:20,928 | ERROR | .features.repos) | configadmin | ? ? |
> 5 - org.apache.felix.configadmin - 1.2.8 |
> [org.osgi.service.cm.ManagedService, id=56, bundle=21]: Unexpected
> problem updating null
>
> java.lang.NullPointerException
>
> at
> org.apache.karaf.features.command.FeatureFinder.updated(FeatureFinder.java:46)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[:1.6.0_24]
>
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)[:1.6.0_24]
>
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)[:1.6.0_24]
>
> at java.lang.reflect.Method.invoke(Method.java:597)[:1.6.0_24]
>
> at
> org.apache.aries.proxy.impl.ProxyHandler$1.invoke(ProxyHandler.java:54)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]
>
> at
> org.apache.aries.proxy.impl.ProxyHandler.invoke(ProxyHandler.java:119)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]
>
> at $Proxy19.updated(Unknown Source)[5:org.apache.felix.configadmin:1.2.8]
>
> at
> org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.run(ConfigurationManager.java:1160)[5:org.apache.felix.configadmin:1.2.8]
>
> at
> org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:104)[5:org.apache.felix.configadmin:1.2.8]
>
> at java.lang.Thread.run(Thread.java:662)[:1.6.0_24]
>
> (2)
>
> 2012-01-17 18:18:49,678 | ERROR | Thread-3 | FeaturesServiceImpl |
> s.internal.FeaturesServiceImpl$1 1029 | 15 -
> org.apache.karaf.features.core - 3.0.0.SNAPSHOT | Error installing boot
> features
>
> java.lang.Exception: Could not start bundle
> mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT
> in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle
> org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing
> requirement [27.0] osgi.wiring.package;
> (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))
>
> at
> org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:407)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
>
> at
> org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:362)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
>
> at
> org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:1027)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
>
> Caused by: org.osgi.framework.BundleException: Unresolved constraint in
> bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0:
> missing requirement [27.0] osgi.wiring.package;
> (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))
>
> at
> org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)[org.apache.felix.framework-4.0.2.jar:]
>
> at
> org.apache.felix.framework.Felix.startBundle(Felix.java:1868)[org.apache.felix.framework-4.0.2.jar:]
>
> at
> org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)[org.apache.felix.framework-4.0.2.jar:]
>
> at
> org.apache.felix.framework.BundleImpl.start(BundleImpl.java:931)[org.apache.felix.framework-4.0.2.jar:]
>
> at
> org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:404)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
>
> ... 2 more
>
> I think this might be org.eclipse.equinox/region/1.0.0.v20110506 missed
> in startup.properties.
>
> (3) when I type TAB on the console, there is error in the log:
>
> 2012-01-17 18:19:33,474 | INFO | l Console Thread | ServiceRecipe |
> viceRecipe$TriggerServiceFactory 497 | 13 -
> org.apache.aries.blueprint.core - 0.4.1.SNAPSHOT | Unable to create a
> proxy object for the service shell-104 defined in bundle
> org.apache.karaf.shell.config at version 3.0.0.SNAPSHOT with id 26.
> Returning the original object instead.
>
> org.apache.aries.proxy.UnableToProxyException: The class
> org.apache.karaf.shell.console.commands.BlueprintCommand is not an
> interface and therefore a proxy cannot be generated.
>
> at
> org.apache.aries.proxy.impl.JdkProxyManager.getInterfaces(JdkProxyManager.java:43)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]
>
> at
> org.apache.aries.proxy.impl.JdkProxyManager.createNewProxy(JdkProxyManager.java:36)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]
>
> …..
>
> I attached the log.
>
> Windows XP SP3, jdk1.6.0_24
>
> Thanks
>
> Guofeng
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

RE: Karaf 3.0.0-SNAPSHOT not works

Guofeng Zhang-2
When the feature frozen, will it have milestone release?

-----Original Message-----
From: Jean-Baptiste Onofré [mailto:[hidden email]]
Sent: Tuesday, January 17, 2012 6:48 PM
To: [hidden email]
Subject: Re: Karaf 3.0.0-SNAPSHOT not works

Hi,

We are in the stabilization phase and feature freeze.

A new snapshot will be deployed soon which fix the issue.

Regards
JB

On 01/17/2012 11:25 AM, Guofeng Zhang wrote:

> Hi,
>
> I update Karaf 3.0.0 SHAPSHOT today and got some error, Kara not stable now.
>
> (1)
>
> 2012-01-17 18:17:20,928 | ERROR | .features.repos) | configadmin | ? ? |
> 5 - org.apache.felix.configadmin - 1.2.8 |
> [org.osgi.service.cm.ManagedService, id=56, bundle=21]: Unexpected
> problem updating null
>
> java.lang.NullPointerException
>
> at
> org.apache.karaf.features.command.FeatureFinder.updated(FeatureFinder.java:46)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[:1.6.0_24]
>
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)[:1.6.0_24]
>
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)[:1.6.0_24]
>
> at java.lang.reflect.Method.invoke(Method.java:597)[:1.6.0_24]
>
> at
> org.apache.aries.proxy.impl.ProxyHandler$1.invoke(ProxyHandler.java:54)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]
>
> at
> org.apache.aries.proxy.impl.ProxyHandler.invoke(ProxyHandler.java:119)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]
>
> at $Proxy19.updated(Unknown Source)[5:org.apache.felix.configadmin:1.2.8]
>
> at
> org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.run(ConfigurationManager.java:1160)[5:org.apache.felix.configadmin:1.2.8]
>
> at
> org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:104)[5:org.apache.felix.configadmin:1.2.8]
>
> at java.lang.Thread.run(Thread.java:662)[:1.6.0_24]
>
> (2)
>
> 2012-01-17 18:18:49,678 | ERROR | Thread-3 | FeaturesServiceImpl |
> s.internal.FeaturesServiceImpl$1 1029 | 15 -
> org.apache.karaf.features.core - 3.0.0.SNAPSHOT | Error installing boot
> features
>
> java.lang.Exception: Could not start bundle
> mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT
> in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle
> org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing
> requirement [27.0] osgi.wiring.package;
> (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))
>
> at
> org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:407)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
>
> at
> org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:362)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
>
> at
> org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:1027)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
>
> Caused by: org.osgi.framework.BundleException: Unresolved constraint in
> bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0:
> missing requirement [27.0] osgi.wiring.package;
> (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))
>
> at
> org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)[org.apache.felix.framework-4.0.2.jar:]
>
> at
> org.apache.felix.framework.Felix.startBundle(Felix.java:1868)[org.apache.felix.framework-4.0.2.jar:]
>
> at
> org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)[org.apache.felix.framework-4.0.2.jar:]
>
> at
> org.apache.felix.framework.BundleImpl.start(BundleImpl.java:931)[org.apache.felix.framework-4.0.2.jar:]
>
> at
> org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:404)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
>
> ... 2 more
>
> I think this might be org.eclipse.equinox/region/1.0.0.v20110506 missed
> in startup.properties.
>
> (3) when I type TAB on the console, there is error in the log:
>
> 2012-01-17 18:19:33,474 | INFO | l Console Thread | ServiceRecipe |
> viceRecipe$TriggerServiceFactory 497 | 13 -
> org.apache.aries.blueprint.core - 0.4.1.SNAPSHOT | Unable to create a
> proxy object for the service shell-104 defined in bundle
> org.apache.karaf.shell.config at version 3.0.0.SNAPSHOT with id 26.
> Returning the original object instead.
>
> org.apache.aries.proxy.UnableToProxyException: The class
> org.apache.karaf.shell.console.commands.BlueprintCommand is not an
> interface and therefore a proxy cannot be generated.
>
> at
> org.apache.aries.proxy.impl.JdkProxyManager.getInterfaces(JdkProxyManager.java:43)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]
>
> at
> org.apache.aries.proxy.impl.JdkProxyManager.createNewProxy(JdkProxyManager.java:36)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]
>
> ...
>
> I attached the log.
>
> Windows XP SP3, jdk1.6.0_24
>
> Thanks
>
> Guofeng
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

RE: Karaf 3.0.0-SNAPSHOT not works

jgoodyear

When the 3.0.0-snapshot is stablized to our satisfaction a release candidate will most likely follow.

Cheers,
Jamie

On Jan 17, 2012 11:02 PM, "Guofeng Zhang" <[hidden email]> wrote:
When the feature frozen, will it have milestone release?

-----Original Message-----
From: Jean-Baptiste Onofré [mailto:[hidden email]]
Sent: Tuesday, January 17, 2012 6:48 PM
To: [hidden email]
Subject: Re: Karaf 3.0.0-SNAPSHOT not works

Hi,

We are in the stabilization phase and feature freeze.

A new snapshot will be deployed soon which fix the issue.

Regards
JB

On 01/17/2012 11:25 AM, Guofeng Zhang wrote:
> Hi,
>
> I update Karaf 3.0.0 SHAPSHOT today and got some error, Kara not stable now.
>
> (1)
>
> <a href="tel:2012-01-17%2018" value="+12012011718">2012-01-17 18:17:20,928 | ERROR | .features.repos) | configadmin | ? ? |
> 5 - org.apache.felix.configadmin - 1.2.8 |
> [org.osgi.service.cm.ManagedService, id=56, bundle=21]: Unexpected
> problem updating null
>
> java.lang.NullPointerException
>
> at
> org.apache.karaf.features.command.FeatureFinder.updated(FeatureFinder.java:46)
>
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[:1.6.0_24]
>
> at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)[:1.6.0_24]
>
> at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)[:1.6.0_24]
>
> at java.lang.reflect.Method.invoke(Method.java:597)[:1.6.0_24]
>
> at
> org.apache.aries.proxy.impl.ProxyHandler$1.invoke(ProxyHandler.java:54)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]
>
> at
> org.apache.aries.proxy.impl.ProxyHandler.invoke(ProxyHandler.java:119)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]
>
> at $Proxy19.updated(Unknown Source)[5:org.apache.felix.configadmin:1.2.8]
>
> at
> org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.run(ConfigurationManager.java:1160)[5:org.apache.felix.configadmin:1.2.8]
>
> at
> org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:104)[5:org.apache.felix.configadmin:1.2.8]
>
> at java.lang.Thread.run(Thread.java:662)[:1.6.0_24]
>
> (2)
>
> <a href="tel:2012-01-17%2018" value="+12012011718">2012-01-17 18:18:49,678 | ERROR | Thread-3 | FeaturesServiceImpl |
> s.internal.FeaturesServiceImpl$1 1029 | 15 -
> org.apache.karaf.features.core - 3.0.0.SNAPSHOT | Error installing boot
> features
>
> java.lang.Exception: Could not start bundle
> mvn:org.apache.karaf.region/org.apache.karaf.region.commands/3.0.0-SNAPSHOT
> in feature(s) region-3.0.0-SNAPSHOT: Unresolved constraint in bundle
> org.apache.karaf.region.commands [27]: Unable to resolve 27.0: missing
> requirement [27.0] osgi.wiring.package;
> (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))
>
> at
> org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:407)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
>
> at
> org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:362)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
>
> at
> org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:1027)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
>
> Caused by: org.osgi.framework.BundleException: Unresolved constraint in
> bundle org.apache.karaf.region.commands [27]: Unable to resolve 27.0:
> missing requirement [27.0] osgi.wiring.package;
> (&(osgi.wiring.package=org.eclipse.equinox.region)(version>=1.0.0)(!(version>=2.0.0)))
>
> at
> org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)[org.apache.felix.framework-4.0.2.jar:]
>
> at
> org.apache.felix.framework.Felix.startBundle(Felix.java:1868)[org.apache.felix.framework-4.0.2.jar:]
>
> at
> org.apache.felix.framework.BundleImpl.start(BundleImpl.java:944)[org.apache.felix.framework-4.0.2.jar:]
>
> at
> org.apache.felix.framework.BundleImpl.start(BundleImpl.java:931)[org.apache.felix.framework-4.0.2.jar:]
>
> at
> org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:404)[15:org.apache.karaf.features.core:3.0.0.SNAPSHOT]
>
> ... 2 more
>
> I think this might be org.eclipse.equinox/region/1.0.0.v20110506 missed
> in startup.properties.
>
> (3) when I type TAB on the console, there is error in the log:
>
> <a href="tel:2012-01-17%2018" value="+12012011718">2012-01-17 18:19:33,474 | INFO | l Console Thread | ServiceRecipe |
> viceRecipe$TriggerServiceFactory 497 | 13 -
> org.apache.aries.blueprint.core - 0.4.1.SNAPSHOT | Unable to create a
> proxy object for the service shell-104 defined in bundle
> org.apache.karaf.shell.config at version 3.0.0.SNAPSHOT with id 26.
> Returning the original object instead.
>
> org.apache.aries.proxy.UnableToProxyException: The class
> org.apache.karaf.shell.console.commands.BlueprintCommand is not an
> interface and therefore a proxy cannot be generated.
>
> at
> org.apache.aries.proxy.impl.JdkProxyManager.getInterfaces(JdkProxyManager.java:43)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]
>
> at
> org.apache.aries.proxy.impl.JdkProxyManager.createNewProxy(JdkProxyManager.java:36)[12:org.apache.aries.proxy.impl:0.4.1.SNAPSHOT]
>
> ...
>
> I attached the log.
>
> Windows XP SP3, jdk1.6.0_24
>
> Thanks
>
> Guofeng
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com