Quantcast

Karaf 4.0.x build is broken

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Karaf 4.0.x build is broken

jbonofre
Hi guys,

As you can see on Jenkins, the karaf-4.0.x branch doesn't build due to
this commit:

https://github.com/apache/karaf/commit/cfda72ece434f6c75af95f7327f5ad1f790c4038

As reminder, Karaf 4.0.x supports both Java7 and Java8. So, the Java
target source level is Java7.

So, something like:

     public URI[] getRepositories() throws IOException {
         load();
         return features.getRepository().stream()
                 .map(String::trim)
                 .map(URI::create)
                 .toArray(URI[]::new);
     }

is not allowed on Karaf 4.0.x (it is on Karaf 4.1.x/master as the Java
version is 8 and 9).

I'm fixing that.

Regards
JB
--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Loading...