Karaf+ActiveMQ WebConsole Issue

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Karaf+ActiveMQ WebConsole Issue

Matt Madhavan
Hello,
I have created an additional broker called "fundation" with couple of Queues. When I start the Webcondole for the ActiveMQ it shows only the default web-console broker. I do not see my broker(foundation) at all!

Do I need to use a different url ?

Thanks
Matt
Reply | Threaded
Open this post in threaded view
|

Re: Karaf+ActiveMQ WebConsole Issue

jbonofre
Hi Matt,

it's a known issue.

I raised https://issues.apache.org/jira/browse/AMQ-3553 about that.

I just have to find some time to work on it :)

Regards
JB

On 12/17/2011 12:05 AM, Matt Madhavan wrote:

> Hello,
> I have created an additional broker called "fundation" with couple of
> Queues. When I start the Webcondole for the ActiveMQ it shows only the
> default web-console broker. I do not see my broker(foundation) at all!
>
> Do I need to use a different url ?
>
> Thanks
> Matt
>
>
> --
> View this message in context: http://karaf.922171.n3.nabble.com/Karaf-ActiveMQ-WebConsole-Issue-tp3592914p3592914.html
> Sent from the Karaf - User mailing list archive at Nabble.com.

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

Re: Karaf+ActiveMQ WebConsole Issue

Andreas Pieber

In fact its a problem with aries jndi. Use karaf 3,upgrade to the aries release candidates for jndi and it works.

Kind regards, Andreas

Send from my mobile. Please excuse the brevity and/or possible auto correction errors.

On Dec 17, 2011 8:17 AM, "Jean-Baptiste Onofré" <[hidden email]> wrote:
Hi Matt,

it's a known issue.

I raised https://issues.apache.org/jira/browse/AMQ-3553 about that.

I just have to find some time to work on it :)

Regards
JB

On 12/17/2011 12:05 AM, Matt Madhavan wrote:
Hello,
I have created an additional broker called "fundation" with couple of
Queues. When I start the Webcondole for the ActiveMQ it shows only the
default web-console broker. I do not see my broker(foundation) at all!

Do I need to use a different url ?

Thanks
Matt


--
View this message in context: http://karaf.922171.n3.nabble.com/Karaf-ActiveMQ-WebConsole-Issue-tp3592914p3592914.html
Sent from the Karaf - User mailing list archive at Nabble.com.

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

Re: Karaf+ActiveMQ WebConsole Issue

Andreas Pieber
btw, another thing here: you'll need something like this in your system.properties (adapted to your settings):

#
# Configuration of the amq web console for the OpenEngSB.
#
webconsole.type=properties
webconsole.jms.url=tcp://localhost:6549
webconsole.jmx.url=service:jmx:rmi:///jndi/rmi://localhost:1099/karaf-openengsb
webconsole.jmx.user=karaf
webconsole.jmx.password=karaf

Kind regards,
Andreas

On Sat, Dec 17, 2011 at 13:10, Andreas Pieber <[hidden email]> wrote:

In fact its a problem with aries jndi. Use karaf 3,upgrade to the aries release candidates for jndi and it works.

Kind regards, Andreas

Send from my mobile. Please excuse the brevity and/or possible auto correction errors.

On Dec 17, 2011 8:17 AM, "Jean-Baptiste Onofré" <[hidden email]> wrote:
Hi Matt,

it's a known issue.

I raised https://issues.apache.org/jira/browse/AMQ-3553 about that.

I just have to find some time to work on it :)

Regards
JB

On 12/17/2011 12:05 AM, Matt Madhavan wrote:
Hello,
I have created an additional broker called "fundation" with couple of
Queues. When I start the Webcondole for the ActiveMQ it shows only the
default web-console broker. I do not see my broker(foundation) at all!

Do I need to use a different url ?

Thanks
Matt


--
View this message in context: http://karaf.922171.n3.nabble.com/Karaf-ActiveMQ-WebConsole-Issue-tp3592914p3592914.html
Sent from the Karaf - User mailing list archive at Nabble.com.

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com

Reply | Threaded
Open this post in threaded view
|

Re: Karaf+ActiveMQ WebConsole Issue

jbonofre
Right Andreas,

my purpose was more to enhance ActiveMQ webconsole to "discover" the
brokers and let the user choose the one that he wants to manipulate.

Regards
JB

On 12/17/2011 04:55 PM, Andreas Pieber wrote:

> btw, another thing here: you'll need something like this in your
> system.properties (adapted to your settings):
>
> #
> # Configuration of the amq web console for the OpenEngSB.
> #
> webconsole.type=properties
> webconsole.jms.url=tcp://localhost:6549
> webconsole.jmx.url=service:jmx:rmi:///jndi/rmi://localhost:1099/karaf-openengsb
> webconsole.jmx.user=karaf
> webconsole.jmx.password=karaf
>
> Kind regards,
> Andreas
>
> On Sat, Dec 17, 2011 at 13:10, Andreas Pieber <[hidden email]
> <mailto:[hidden email]>> wrote:
>
>     In fact its a problem with aries jndi. Use karaf 3,upgrade to the
>     aries release candidates for jndi and it works.
>
>     Kind regards, Andreas
>
>     Send from my mobile. Please excuse the brevity and/or possible auto
>     correction errors.
>
>     On Dec 17, 2011 8:17 AM, "Jean-Baptiste Onofré" <[hidden email]
>     <mailto:[hidden email]>> wrote:
>
>         Hi Matt,
>
>         it's a known issue.
>
>         I raised https://issues.apache.org/__jira/browse/AMQ-3553
>         <https://issues.apache.org/jira/browse/AMQ-3553> about that.
>
>         I just have to find some time to work on it :)
>
>         Regards
>         JB
>
>         On 12/17/2011 12:05 AM, Matt Madhavan wrote:
>
>             Hello,
>             I have created an additional broker called "fundation" with
>             couple of
>             Queues. When I start the Webcondole for the ActiveMQ it
>             shows only the
>             default web-console broker. I do not see my
>             broker(foundation) at all!
>
>             Do I need to use a different url ?
>
>             Thanks
>             Matt
>
>
>             --
>             View this message in context:
>             http://karaf.922171.n3.nabble.__com/Karaf-ActiveMQ-WebConsole-__Issue-tp3592914p3592914.html
>             <http://karaf.922171.n3.nabble.com/Karaf-ActiveMQ-WebConsole-Issue-tp3592914p3592914.html>
>             Sent from the Karaf - User mailing list archive at Nabble.com.
>
>
>         --
>         Jean-Baptiste Onofré
>         [hidden email] <mailto:[hidden email]>
>         http://blog.nanthrax.net
>         Talend - http://www.talend.com
>
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

Re: Karaf+ActiveMQ WebConsole Issue

Matt Madhavan
Hi Andreas,
I do have the system.properties file configured!

And JB,
In the mean time is  there any way you can export the javax.jms.ConnrectionFactory of the web-console as an OSGi service like the one below!

  <service ref="pooledConnectionFactory" interface="javax.jms.ConnectionFactory">
    <service-properties>
      <entry key="name" value="foundation" />
    </service-properties>
  </service>

I have a requirement where I had to look up the ConnectionFactory vid jndi/ServiceLookUp. I'm sure others will have a similar need as well.

Thanks
Matt