Karaf : CXF and Websocket (!!!Does not work) - SSE (Works)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Karaf : CXF and Websocket (!!!Does not work) - SSE (Works)

Byrebg
I followed the cxf web socket support tutorial as suggested in link

Websocket-OSGI
<https://github.com/apache/cxf/tree/master/distribution/src/main/release/samples/jax_rs/websocket_osgi>  

KARAF_4_1_3
<http://karaf.922171.n3.nabble.com/file/t497932/KARAF_Installation.gif>


On testing with node client it works fine with *SSE* with notification sent
to
client

<http://karaf.922171.n3.nabble.com/file/t497932/sse.gif>

*Websocket* /fails to connect/

<http://karaf.922171.n3.nabble.com/file/t497932/websocket_fails.gif>

Ensured blueprint file has the right address and transport id, as stated in
the example

 
    <bean id="sampleResource" class="com.demo.websocket2.CustomerService" />

    <cxf:bus>
        <cxf:features>
            <cxf:logging />
        </cxf:features>
    </cxf:bus>

    <jaxrs:server id="websocketSampleService" address="/websocketSample"
transportId="http://cxf.apache.org/transports/websocket">
        <jaxrs:serviceBeans>
            <ref component-id="sampleResource" />
        </jaxrs:serviceBeans>
    </jaxrs:server>

Since i am not able to get right error info, any suggestion or hint would be
helpful

Regards
BG




--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
Reply | Threaded
Open this post in threaded view
|

Re: Karaf : CXF and Websocket (!!!Does not work) - SSE (Works)

Byrebg
We cross-checked with latest KARAF 4.1.5, still we are encountering the
issue. Any support or direction to debug issue would be helpful



--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
Reply | Threaded
Open this post in threaded view
|

Re: Karaf : CXF and Websocket (!!!Does not work) - SSE (Works)

jbonofre
Thanks for the update. We will take a look.

Regards
JB

On 10/04/2018 09:18, Byrebg wrote:
> We cross-checked with latest KARAF 4.1.5, still we are encountering the
> issue. Any support or direction to debug issue would be helpful
>
>
>
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-User-f930749.html
>