Start of karaf 4.2.6 no more possible - because of 4.3.0 RC1 features

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Start of karaf 4.2.6 no more possible - because of 4.3.0 RC1 features

Mike Hummel
Hello,

a problem with new features again. The following error occurred if i start the assembly:

20:13:45.259 ERROR [activator-1-thread-2] Error installing boot features
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=framework; type=karaf.feature; version="[4.2.6,4.2.6]"; filter:="(&(osgi.identity=framework)(type=karaf.feature)(version>=4.2.6)(version<=4.2.6))" [caused by: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]]


I have the following pom plugin config:


            <plugin>
                <groupId>org.apache.karaf.tooling</groupId>
                <artifactId>karaf-maven-plugin</artifactId>
                <extensions>true</extensions>
                <configuration>
                    <archiveZip>false</archiveZip>
                    <targetFile>assembly</targetFile>

                    

    <blacklistedRepositories>

                        <repository>mvn:org.apache.karaf.features/framework/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/standard/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring-legacy/4.2.8/xml/features</repository>

                        <repository>mvn:org.apache.karaf.features/framework/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/standard/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring-legacy/4.2.7/xml/features</repository>

   

        <repository>mvn:org.apache.karaf.features/framework/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/standard/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/spring/4.3.0-SNAPSHOT/xml/features</repository>

        <repository>mvn:org.apache.karaf.features/framework/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/standard/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/spring/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/org.apache.karaf.features.extension/4.3.0.RC1/*</repository>

        <!--
        <repository>mvn:org.apache.karaf.features/spring-legacy/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.ops4j.pax.web/pax-web-features/7.2.10/xml/features</repository>
        -->
        <repository>mvn:org.ops4j.pax.web/pax-web-features/7.2.11/xml/features</repository>
        <repository>mvn:org.ops4j.pax.web/pax-web-features/7.2.12/xml/features</repository>
    </blacklistedRepositories>
                    <bootFeatures>
                        <feature>standard</feature>

                        

                        <feature>scr</feature>
                        <feature>http-whiteboard</feature>
                         <feature>deployer/${karaf.version}</feature>
                         <feature>aries-blueprint/${karaf.version}</feature>
                         <feature>cxf-core/${cxf.version}</feature>
                         <feature>openjpa3/3.0.0</feature>
                         <feature>activemq-client/${activemq.version}</feature>

                         

                        <feature>bundle</feature>
                        <feature>config</feature>
                        <feature>diagnostic</feature>
                        <feature>feature</feature>
                        <feature>jaas</feature>
                        <feature>shell</feature>
                        <feature>log</feature>
                        <feature>management</feature>
                        <feature>package</feature>
                        <feature>shell-compat</feature>
                        <feature>ssh</feature>
                        <feature>system</feature>
                        <feature>wrap</feature>
                        <feature>wrapper</feature>


                        <feature>app</feature>

                         

                    </bootFeatures>
                    <installedFeatures>
                    </installedFeatures>
                    <javase>11</javase>
                </configuration>

                

<executions>
  <execution>
    <phase>compile</phase>
      <goals>
        <goal>assembly</goal>
      </goals>
    </execution>
    <execution>
      <id>package</id>
      <goals>
        <goal>archive</goal>
      </goals>
    </execution>
</executions>                
            </plugin>


It looks like the following is the problem

mvn:org.apache.karaf.features/org.apache.karaf.features.extension

I already played around with

<repository>mvn:org.apache.karaf.features/org.apache.karaf.features.extension/4.3.0.RC1/*</repository>

but got no positive result...

Thx & Regards,

Mike

The full error:

Feb 06, 2020 8:13:42 PM org.apache.karaf.main.Main launch
INFO: Installing and starting initial bundles
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.Main launch
INFO: All initial bundles installed and set to start
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.lock.SimpleFileLock lock
INFO: Trying to lock /Users/mikehummel/MHU/workspaces/crypta/doe-crypta/assembly/assembly-core/target/assembly/lock
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.lock.SimpleFileLock lock
INFO: Lock acquired
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.Main$KarafLockCallback lockAcquired
INFO: Lock acquired. Setting startlevel to 100
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling SLF4J API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Jakarta Commons Logging API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Log4J API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Avalon Logger API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling JULI Logger API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Log4J v2 API support. Ignored FQCN: org.apache.logging.log4j.spi.AbstractLogger
20:13:43.917 WARN  [activator-1-thread-2] Old style feature file without namespace found (URI: mvn:org.apache.activemq/activemq-karaf/5.15.8/xml/features-core). This format is deprecated and support for it will soon be removed
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.990 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.990 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.011 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.012 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.012 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.012 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.054 INFO  [activator-1-thread-2] Adding features: wrap/[2.6.2,2.6.2]
20:13:44.130 INFO  [features-3-thread-1] Changes to perform:
20:13:44.131 INFO  [features-3-thread-1]   Region: root
20:13:44.131 INFO  [features-3-thread-1]     Bundles to install:
20:13:44.131 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.url/pax-url-wrap/2.6.2/jar/uber
20:13:44.132 INFO  [features-3-thread-1] Installing bundles:
20:13:44.132 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.url/pax-url-wrap/2.6.2/jar/uber
20:13:44.152 INFO  [features-3-thread-1] Starting bundles:
20:13:44.153 INFO  [features-3-thread-1]   org.ops4j.pax.url.wrap/2.6.2
20:13:44.157 INFO  [features-3-thread-1] Done.
20:13:44.160 INFO  [activator-1-thread-2] Adding features: cxf-core/[3.3.1,3.3.1],wrapper/[4.2.6,4.2.6],framework/[4.2.6,4.2.6],openjpa3/[3.0.0,3.0.0],jaas/[4.2.6,4.2.6],package/[4.2.6,4.2.6],feature/[4.2.6,4.2.6],config/[4.2.6,4.2.6],http-whiteboard/[4.2.6,4.2.6],shell-compat/[4.2.6,4.2.6],scr/[4.2.6,4.2.6],deployer/[4.2.6,4.2.6],diagnostic/[4.2.6,4.2.6],shell/[4.2.6,4.2.6],management/[4.2.6,4.2.6],log/[4.2.6,4.2.6],crypta-core/[1.0.0.SNAPSHOT,1.0.0.SNAPSHOT],ssh/[4.2.6,4.2.6],system/[4.2.6,4.2.6],standard/[4.2.6,4.2.6],aries-blueprint/[4.2.6,4.2.6],activemq-client/[5.15.8,5.15.8],bundle/[4.2.6,4.2.6]
20:13:44.203 INFO  [features-3-thread-1] Changes to perform:
20:13:44.204 INFO  [features-3-thread-1]   Region: root
20:13:44.204 INFO  [features-3-thread-1]     Bundles to install:
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.2_1
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.jdbc/pax-jdbc/1.3.5
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.3.5
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.3.5
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.osgi/org.osgi.service.jdbc/1.0.0
20:13:44.204 INFO  [features-3-thread-1] Installing bundles:
20:13:44.205 INFO  [features-3-thread-1]   mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
20:13:44.208 INFO  [features-3-thread-1]   mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.2_1
20:13:44.211 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.jdbc/pax-jdbc/1.3.5
20:13:44.213 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.3.5
20:13:44.215 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.3.5
20:13:44.217 INFO  [features-3-thread-1]   mvn:org.osgi/org.osgi.service.jdbc/1.0.0
20:13:44.232 INFO  [features-3-thread-1] Starting bundles:
20:13:44.233 INFO  [features-3-thread-1]   org.apache.geronimo.specs.geronimo-jta_1.1_spec/1.1.1
20:13:44.233 INFO  [features-3-thread-1]   org.osgi.service.jdbc/1.0.0.201505202023
20:13:44.234 INFO  [features-3-thread-1]   org.ops4j.pax.jdbc.pool.common/1.3.5
20:13:44.235 INFO  [features-3-thread-1]   org.ops4j.pax.jdbc/1.3.5
20:13:44.245 INFO  [features-3-thread-1]   org.apache.servicemix.bundles.jasypt/1.9.2.1
20:13:44.247 INFO  [features-3-thread-1]   org.ops4j.pax.jdbc.config/1.3.5
20:13:44.254 INFO  [features-3-thread-1] Obtained service dependency: (objectClass=org.ops4j.pax.jdbc.config.ConfigLoader)
20:13:44.255 INFO  [features-3-thread-1] Waiting for service dependency: (objectClass=org.ops4j.pax.jdbc.config.ConfigLoader)
20:13:44.260 INFO  [features-3-thread-1] Waiting for service dependency: (&(pool=*)(!(pax.jdbc.managed=true))(|(objectClass=javax.sql.DataSource)(objectClass=javax.sql.XADataSource)))
20:13:44.261 INFO  [features-3-thread-1] Done.
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=framework; type=karaf.feature; version="[4.2.6,4.2.6]"; filter:="(&(osgi.identity=framework)(type=karaf.feature)(version>=4.2.6)(version<=4.2.6))" [caused by: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
... 12 more
Caused by: org.apache.felix.resolver.reason.ReasonException: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)
at org.apache.felix.resolver.Candidates$FragmentNotSelectedError.toException(Candidates.java:1307)
... 13 more
20:13:45.259 ERROR [activator-1-thread-2] Error installing boot features
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=framework; type=karaf.feature; version="[4.2.6,4.2.6]"; filter:="(&(osgi.identity=framework)(type=karaf.feature)(version>=4.2.6)(version<=4.2.6))" [caused by: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
... 12 more
Caused by: org.apache.felix.resolver.reason.ReasonException: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)
at org.apache.felix.resolver.Candidates$FragmentNotSelectedError.toException(Candidates.java:1307)
... 13 more






Reply | Threaded
Open this post in threaded view
|

Re: Start of karaf 4.2.6 no more possible - because of 4.3.0 RC1 features

jbonofre
Hi,

First side note: I don’t see event admin as startup feature. Can you please try to add event admin feature at startup ?

Can you please share the whole pom.xml with me ? I would like to check the dependencies scope.

What’s your environment (JDK, OS, …) ?

Regards
JB

Le 6 févr. 2020 à 20:21, Mike Hummel <[hidden email]> a écrit :

Hello,

a problem with new features again. The following error occurred if i start the assembly:

20:13:45.259 ERROR [activator-1-thread-2] Error installing boot features
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=framework; type=karaf.feature; version="[4.2.6,4.2.6]"; filter:="(&(osgi.identity=framework)(type=karaf.feature)(version>=4.2.6)(version<=4.2.6))" [caused by: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]]


I have the following pom plugin config:


            <plugin>
                <groupId>org.apache.karaf.tooling</groupId>
                <artifactId>karaf-maven-plugin</artifactId>
                <extensions>true</extensions>
                <configuration>
                    <archiveZip>false</archiveZip>
                    <targetFile>assembly</targetFile>
                    
    <blacklistedRepositories>

                        <repository>mvn:org.apache.karaf.features/framework/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/standard/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring-legacy/4.2.8/xml/features</repository>

                        <repository>mvn:org.apache.karaf.features/framework/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/standard/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring-legacy/4.2.7/xml/features</repository>
   
        <repository>mvn:org.apache.karaf.features/framework/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/standard/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/spring/4.3.0-SNAPSHOT/xml/features</repository>

        <repository>mvn:org.apache.karaf.features/framework/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/standard/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/spring/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/org.apache.karaf.features.extension/4.3.0.RC1/*</repository>

        <!--
        <repository>mvn:org.apache.karaf.features/spring-legacy/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.ops4j.pax.web/pax-web-features/7.2.10/xml/features</repository>
        -->
        <repository>mvn:org.ops4j.pax.web/pax-web-features/7.2.11/xml/features</repository>
        <repository>mvn:org.ops4j.pax.web/pax-web-features/7.2.12/xml/features</repository>
    </blacklistedRepositories>
                    <bootFeatures>
                        <feature>standard</feature>
                        
                        <feature>scr</feature>
                        <feature>http-whiteboard</feature>
                         <feature>deployer/${karaf.version}</feature>
                         <feature>aries-blueprint/${karaf.version}</feature>
                         <feature>cxf-core/${cxf.version}</feature>
                         <feature>openjpa3/3.0.0</feature>
                         <feature>activemq-client/${activemq.version}</feature>
                         
                        <feature>bundle</feature>
                        <feature>config</feature>
                        <feature>diagnostic</feature>
                        <feature>feature</feature>
                        <feature>jaas</feature>
                        <feature>shell</feature>
                        <feature>log</feature>
                        <feature>management</feature>
                        <feature>package</feature>
                        <feature>shell-compat</feature>
                        <feature>ssh</feature>
                        <feature>system</feature>
                        <feature>wrap</feature>
                        <feature>wrapper</feature>

                        <feature>app</feature>
                         
                    </bootFeatures>
                    <installedFeatures>
                    </installedFeatures>
                    <javase>11</javase>
                </configuration>
                
<executions>
  <execution>
    <phase>compile</phase>
      <goals>
        <goal>assembly</goal>
      </goals>
    </execution>
    <execution>
      <id>package</id>
      <goals>
        <goal>archive</goal>
      </goals>
    </execution>
</executions>                
            </plugin>


It looks like the following is the problem

mvn:org.apache.karaf.features/org.apache.karaf.features.extension

I already played around with

<repository>mvn:org.apache.karaf.features/org.apache.karaf.features.extension/4.3.0.RC1/*</repository>

but got no positive result...

Thx & Regards,

Mike

The full error:

Feb 06, 2020 8:13:42 PM org.apache.karaf.main.Main launch
INFO: Installing and starting initial bundles
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.Main launch
INFO: All initial bundles installed and set to start
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.lock.SimpleFileLock lock
INFO: Trying to lock /Users/mikehummel/MHU/workspaces/crypta/doe-crypta/assembly/assembly-core/target/assembly/lock
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.lock.SimpleFileLock lock
INFO: Lock acquired
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.Main$KarafLockCallback lockAcquired
INFO: Lock acquired. Setting startlevel to 100
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling SLF4J API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Jakarta Commons Logging API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Log4J API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Avalon Logger API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling JULI Logger API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Log4J v2 API support. Ignored FQCN: org.apache.logging.log4j.spi.AbstractLogger
20:13:43.917 WARN  [activator-1-thread-2] Old style feature file without namespace found (URI: mvn:org.apache.activemq/activemq-karaf/5.15.8/xml/features-core). This format is deprecated and support for it will soon be removed
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.990 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.990 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.011 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.012 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.012 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.012 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.054 INFO  [activator-1-thread-2] Adding features: wrap/[2.6.2,2.6.2]
20:13:44.130 INFO  [features-3-thread-1] Changes to perform:
20:13:44.131 INFO  [features-3-thread-1]   Region: root
20:13:44.131 INFO  [features-3-thread-1]     Bundles to install:
20:13:44.131 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.url/pax-url-wrap/2.6.2/jar/uber
20:13:44.132 INFO  [features-3-thread-1] Installing bundles:
20:13:44.132 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.url/pax-url-wrap/2.6.2/jar/uber
20:13:44.152 INFO  [features-3-thread-1] Starting bundles:
20:13:44.153 INFO  [features-3-thread-1]   org.ops4j.pax.url.wrap/2.6.2
20:13:44.157 INFO  [features-3-thread-1] Done.
20:13:44.160 INFO  [activator-1-thread-2] Adding features: cxf-core/[3.3.1,3.3.1],wrapper/[4.2.6,4.2.6],framework/[4.2.6,4.2.6],openjpa3/[3.0.0,3.0.0],jaas/[4.2.6,4.2.6],package/[4.2.6,4.2.6],feature/[4.2.6,4.2.6],config/[4.2.6,4.2.6],http-whiteboard/[4.2.6,4.2.6],shell-compat/[4.2.6,4.2.6],scr/[4.2.6,4.2.6],deployer/[4.2.6,4.2.6],diagnostic/[4.2.6,4.2.6],shell/[4.2.6,4.2.6],management/[4.2.6,4.2.6],log/[4.2.6,4.2.6],crypta-core/[1.0.0.SNAPSHOT,1.0.0.SNAPSHOT],ssh/[4.2.6,4.2.6],system/[4.2.6,4.2.6],standard/[4.2.6,4.2.6],aries-blueprint/[4.2.6,4.2.6],activemq-client/[5.15.8,5.15.8],bundle/[4.2.6,4.2.6]
20:13:44.203 INFO  [features-3-thread-1] Changes to perform:
20:13:44.204 INFO  [features-3-thread-1]   Region: root
20:13:44.204 INFO  [features-3-thread-1]     Bundles to install:
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.2_1
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.jdbc/pax-jdbc/1.3.5
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.3.5
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.3.5
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.osgi/org.osgi.service.jdbc/1.0.0
20:13:44.204 INFO  [features-3-thread-1] Installing bundles:
20:13:44.205 INFO  [features-3-thread-1]   mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
20:13:44.208 INFO  [features-3-thread-1]   mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.2_1
20:13:44.211 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.jdbc/pax-jdbc/1.3.5
20:13:44.213 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.3.5
20:13:44.215 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.3.5
20:13:44.217 INFO  [features-3-thread-1]   mvn:org.osgi/org.osgi.service.jdbc/1.0.0
20:13:44.232 INFO  [features-3-thread-1] Starting bundles:
20:13:44.233 INFO  [features-3-thread-1]   org.apache.geronimo.specs.geronimo-jta_1.1_spec/1.1.1
20:13:44.233 INFO  [features-3-thread-1]   org.osgi.service.jdbc/1.0.0.201505202023
20:13:44.234 INFO  [features-3-thread-1]   org.ops4j.pax.jdbc.pool.common/1.3.5
20:13:44.235 INFO  [features-3-thread-1]   org.ops4j.pax.jdbc/1.3.5
20:13:44.245 INFO  [features-3-thread-1]   org.apache.servicemix.bundles.jasypt/1.9.2.1
20:13:44.247 INFO  [features-3-thread-1]   org.ops4j.pax.jdbc.config/1.3.5
20:13:44.254 INFO  [features-3-thread-1] Obtained service dependency: (objectClass=org.ops4j.pax.jdbc.config.ConfigLoader)
20:13:44.255 INFO  [features-3-thread-1] Waiting for service dependency: (objectClass=org.ops4j.pax.jdbc.config.ConfigLoader)
20:13:44.260 INFO  [features-3-thread-1] Waiting for service dependency: (&(pool=*)(!(pax.jdbc.managed=true))(|(objectClass=javax.sql.DataSource)(objectClass=javax.sql.XADataSource)))
20:13:44.261 INFO  [features-3-thread-1] Done.
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=framework; type=karaf.feature; version="[4.2.6,4.2.6]"; filter:="(&(osgi.identity=framework)(type=karaf.feature)(version>=4.2.6)(version<=4.2.6))" [caused by: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
... 12 more
Caused by: org.apache.felix.resolver.reason.ReasonException: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)
at org.apache.felix.resolver.Candidates$FragmentNotSelectedError.toException(Candidates.java:1307)
... 13 more
20:13:45.259 ERROR [activator-1-thread-2] Error installing boot features
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=framework; type=karaf.feature; version="[4.2.6,4.2.6]"; filter:="(&(osgi.identity=framework)(type=karaf.feature)(version>=4.2.6)(version<=4.2.6))" [caused by: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
... 12 more
Caused by: org.apache.felix.resolver.reason.ReasonException: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)
at org.apache.felix.resolver.Candidates$FragmentNotSelectedError.toException(Candidates.java:1307)
... 13 more







Reply | Threaded
Open this post in threaded view
|

Re: Start of karaf 4.2.6 no more possible - because of 4.3.0 RC1 features

Mike Hummel
Hi,

it's the mail effect ... found the problem.

added

<repository>mvn:org.apache.karaf.features/spring-legacy/4.3.0.RC1/xml/features</repository>

to the blacklist. Found it in the output of creation of the assembly.

[INFO]       adding feature repository: mvn:org.apache.karaf.features/spring-legacy/4.3.0.RC1/xml/features

Thx. 

PS: Is there a status of the pull request for the 'repo whitelist' in 4.3.0 ? https://github.com/apache/karaf/pull/1020
This will fix this annoying issues... ;-)



On 6. Feb 2020, at 20:32, Jean-Baptiste Onofre <[hidden email]> wrote:

Hi,

First side note: I don’t see event admin as startup feature. Can you please try to add event admin feature at startup ?

Can you please share the whole pom.xml with me ? I would like to check the dependencies scope.

What’s your environment (JDK, OS, …) ?

Regards
JB

Le 6 févr. 2020 à 20:21, Mike Hummel <[hidden email]> a écrit :

Hello,

a problem with new features again. The following error occurred if i start the assembly:

20:13:45.259 ERROR [activator-1-thread-2] Error installing boot features
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=framework; type=karaf.feature; version="[4.2.6,4.2.6]"; filter:="(&(osgi.identity=framework)(type=karaf.feature)(version>=4.2.6)(version<=4.2.6))" [caused by: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]]


I have the following pom plugin config:


            <plugin>
                <groupId>org.apache.karaf.tooling</groupId>
                <artifactId>karaf-maven-plugin</artifactId>
                <extensions>true</extensions>
                <configuration>
                    <archiveZip>false</archiveZip>
                    <targetFile>assembly</targetFile>
                    
    <blacklistedRepositories>

                        <repository>mvn:org.apache.karaf.features/framework/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/standard/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring-legacy/4.2.8/xml/features</repository>

                        <repository>mvn:org.apache.karaf.features/framework/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/standard/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring-legacy/4.2.7/xml/features</repository>
   
        <repository>mvn:org.apache.karaf.features/framework/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/standard/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/spring/4.3.0-SNAPSHOT/xml/features</repository>

        <repository>mvn:org.apache.karaf.features/framework/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/standard/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/spring/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/org.apache.karaf.features.extension/4.3.0.RC1/*</repository>

        <!--
        <repository>mvn:org.apache.karaf.features/spring-legacy/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.ops4j.pax.web/pax-web-features/7.2.10/xml/features</repository>
        -->
        <repository>mvn:org.ops4j.pax.web/pax-web-features/7.2.11/xml/features</repository>
        <repository>mvn:org.ops4j.pax.web/pax-web-features/7.2.12/xml/features</repository>
    </blacklistedRepositories>
                    <bootFeatures>
                        <feature>standard</feature>
                        
                        <feature>scr</feature>
                        <feature>http-whiteboard</feature>
                         <feature>deployer/${karaf.version}</feature>
                         <feature>aries-blueprint/${karaf.version}</feature>
                         <feature>cxf-core/${cxf.version}</feature>
                         <feature>openjpa3/3.0.0</feature>
                         <feature>activemq-client/${activemq.version}</feature>
                         
                        <feature>bundle</feature>
                        <feature>config</feature>
                        <feature>diagnostic</feature>
                        <feature>feature</feature>
                        <feature>jaas</feature>
                        <feature>shell</feature>
                        <feature>log</feature>
                        <feature>management</feature>
                        <feature>package</feature>
                        <feature>shell-compat</feature>
                        <feature>ssh</feature>
                        <feature>system</feature>
                        <feature>wrap</feature>
                        <feature>wrapper</feature>

                        <feature>app</feature>
                         
                    </bootFeatures>
                    <installedFeatures>
                    </installedFeatures>
                    <javase>11</javase>
                </configuration>
                
<executions>
  <execution>
    <phase>compile</phase>
      <goals>
        <goal>assembly</goal>
      </goals>
    </execution>
    <execution>
      <id>package</id>
      <goals>
        <goal>archive</goal>
      </goals>
    </execution>
</executions>                
            </plugin>


It looks like the following is the problem

mvn:org.apache.karaf.features/org.apache.karaf.features.extension

I already played around with

<repository>mvn:org.apache.karaf.features/org.apache.karaf.features.extension/4.3.0.RC1/*</repository>

but got no positive result...

Thx & Regards,

Mike

The full error:

Feb 06, 2020 8:13:42 PM org.apache.karaf.main.Main launch
INFO: Installing and starting initial bundles
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.Main launch
INFO: All initial bundles installed and set to start
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.lock.SimpleFileLock lock
INFO: Trying to lock /Users/mikehummel/MHU/workspaces/crypta/doe-crypta/assembly/assembly-core/target/assembly/lock
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.lock.SimpleFileLock lock
INFO: Lock acquired
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.Main$KarafLockCallback lockAcquired
INFO: Lock acquired. Setting startlevel to 100
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling SLF4J API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Jakarta Commons Logging API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Log4J API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Avalon Logger API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling JULI Logger API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Log4J v2 API support. Ignored FQCN: org.apache.logging.log4j.spi.AbstractLogger
20:13:43.917 WARN  [activator-1-thread-2] Old style feature file without namespace found (URI: mvn:org.apache.activemq/activemq-karaf/5.15.8/xml/features-core). This format is deprecated and support for it will soon be removed
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.990 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.990 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.011 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.012 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.012 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.012 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.054 INFO  [activator-1-thread-2] Adding features: wrap/[2.6.2,2.6.2]
20:13:44.130 INFO  [features-3-thread-1] Changes to perform:
20:13:44.131 INFO  [features-3-thread-1]   Region: root
20:13:44.131 INFO  [features-3-thread-1]     Bundles to install:
20:13:44.131 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.url/pax-url-wrap/2.6.2/jar/uber
20:13:44.132 INFO  [features-3-thread-1] Installing bundles:
20:13:44.132 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.url/pax-url-wrap/2.6.2/jar/uber
20:13:44.152 INFO  [features-3-thread-1] Starting bundles:
20:13:44.153 INFO  [features-3-thread-1]   org.ops4j.pax.url.wrap/2.6.2
20:13:44.157 INFO  [features-3-thread-1] Done.
20:13:44.160 INFO  [activator-1-thread-2] Adding features: cxf-core/[3.3.1,3.3.1],wrapper/[4.2.6,4.2.6],framework/[4.2.6,4.2.6],openjpa3/[3.0.0,3.0.0],jaas/[4.2.6,4.2.6],package/[4.2.6,4.2.6],feature/[4.2.6,4.2.6],config/[4.2.6,4.2.6],http-whiteboard/[4.2.6,4.2.6],shell-compat/[4.2.6,4.2.6],scr/[4.2.6,4.2.6],deployer/[4.2.6,4.2.6],diagnostic/[4.2.6,4.2.6],shell/[4.2.6,4.2.6],management/[4.2.6,4.2.6],log/[4.2.6,4.2.6],crypta-core/[1.0.0.SNAPSHOT,1.0.0.SNAPSHOT],ssh/[4.2.6,4.2.6],system/[4.2.6,4.2.6],standard/[4.2.6,4.2.6],aries-blueprint/[4.2.6,4.2.6],activemq-client/[5.15.8,5.15.8],bundle/[4.2.6,4.2.6]
20:13:44.203 INFO  [features-3-thread-1] Changes to perform:
20:13:44.204 INFO  [features-3-thread-1]   Region: root
20:13:44.204 INFO  [features-3-thread-1]     Bundles to install:
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.2_1
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.jdbc/pax-jdbc/1.3.5
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.3.5
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.3.5
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.osgi/org.osgi.service.jdbc/1.0.0
20:13:44.204 INFO  [features-3-thread-1] Installing bundles:
20:13:44.205 INFO  [features-3-thread-1]   mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
20:13:44.208 INFO  [features-3-thread-1]   mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.2_1
20:13:44.211 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.jdbc/pax-jdbc/1.3.5
20:13:44.213 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.3.5
20:13:44.215 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.3.5
20:13:44.217 INFO  [features-3-thread-1]   mvn:org.osgi/org.osgi.service.jdbc/1.0.0
20:13:44.232 INFO  [features-3-thread-1] Starting bundles:
20:13:44.233 INFO  [features-3-thread-1]   org.apache.geronimo.specs.geronimo-jta_1.1_spec/1.1.1
20:13:44.233 INFO  [features-3-thread-1]   org.osgi.service.jdbc/1.0.0.201505202023
20:13:44.234 INFO  [features-3-thread-1]   org.ops4j.pax.jdbc.pool.common/1.3.5
20:13:44.235 INFO  [features-3-thread-1]   org.ops4j.pax.jdbc/1.3.5
20:13:44.245 INFO  [features-3-thread-1]   org.apache.servicemix.bundles.jasypt/1.9.2.1
20:13:44.247 INFO  [features-3-thread-1]   org.ops4j.pax.jdbc.config/1.3.5
20:13:44.254 INFO  [features-3-thread-1] Obtained service dependency: (objectClass=org.ops4j.pax.jdbc.config.ConfigLoader)
20:13:44.255 INFO  [features-3-thread-1] Waiting for service dependency: (objectClass=org.ops4j.pax.jdbc.config.ConfigLoader)
20:13:44.260 INFO  [features-3-thread-1] Waiting for service dependency: (&(pool=*)(!(pax.jdbc.managed=true))(|(objectClass=javax.sql.DataSource)(objectClass=javax.sql.XADataSource)))
20:13:44.261 INFO  [features-3-thread-1] Done.
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=framework; type=karaf.feature; version="[4.2.6,4.2.6]"; filter:="(&(osgi.identity=framework)(type=karaf.feature)(version>=4.2.6)(version<=4.2.6))" [caused by: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
... 12 more
Caused by: org.apache.felix.resolver.reason.ReasonException: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)
at org.apache.felix.resolver.Candidates$FragmentNotSelectedError.toException(Candidates.java:1307)
... 13 more
20:13:45.259 ERROR [activator-1-thread-2] Error installing boot features
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=framework; type=karaf.feature; version="[4.2.6,4.2.6]"; filter:="(&(osgi.identity=framework)(type=karaf.feature)(version>=4.2.6)(version<=4.2.6))" [caused by: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
... 12 more
Caused by: org.apache.felix.resolver.reason.ReasonException: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)
at org.apache.felix.resolver.Candidates$FragmentNotSelectedError.toException(Candidates.java:1307)
... 13 more








Reply | Threaded
Open this post in threaded view
|

Re: Start of karaf 4.2.6 no more possible - because of 4.3.0 RC1 features

jbonofre
Good catch.

Anyway, don’t forget the event admin feature in startup (it’s not the “Felix“ regular event admin bundle).

Regards
JB

Le 6 févr. 2020 à 20:54, Mike Hummel <[hidden email]> a écrit :

Hi,

it's the mail effect ... found the problem.

added

<repository>mvn:org.apache.karaf.features/spring-legacy/4.3.0.RC1/xml/features</repository>

to the blacklist. Found it in the output of creation of the assembly.

[INFO]       adding feature repository: mvn:org.apache.karaf.features/spring-legacy/4.3.0.RC1/xml/features

Thx. 

PS: Is there a status of the pull request for the 'repo whitelist' in 4.3.0 ? https://github.com/apache/karaf/pull/1020
This will fix this annoying issues... ;-)



On 6. Feb 2020, at 20:32, Jean-Baptiste Onofre <[hidden email]> wrote:

Hi,

First side note: I don’t see event admin as startup feature. Can you please try to add event admin feature at startup ?

Can you please share the whole pom.xml with me ? I would like to check the dependencies scope.

What’s your environment (JDK, OS, …) ?

Regards
JB

Le 6 févr. 2020 à 20:21, Mike Hummel <[hidden email]> a écrit :

Hello,

a problem with new features again. The following error occurred if i start the assembly:

20:13:45.259 ERROR [activator-1-thread-2] Error installing boot features
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=framework; type=karaf.feature; version="[4.2.6,4.2.6]"; filter:="(&(osgi.identity=framework)(type=karaf.feature)(version>=4.2.6)(version<=4.2.6))" [caused by: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]]


I have the following pom plugin config:


            <plugin>
                <groupId>org.apache.karaf.tooling</groupId>
                <artifactId>karaf-maven-plugin</artifactId>
                <extensions>true</extensions>
                <configuration>
                    <archiveZip>false</archiveZip>
                    <targetFile>assembly</targetFile>
                    
    <blacklistedRepositories>

                        <repository>mvn:org.apache.karaf.features/framework/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/standard/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring/4.2.8/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring-legacy/4.2.8/xml/features</repository>

                        <repository>mvn:org.apache.karaf.features/framework/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/standard/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring/4.2.7/xml/features</repository>
                        <repository>mvn:org.apache.karaf.features/spring-legacy/4.2.7/xml/features</repository>
   
        <repository>mvn:org.apache.karaf.features/framework/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/standard/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/spring/4.3.0-SNAPSHOT/xml/features</repository>

        <repository>mvn:org.apache.karaf.features/framework/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/standard/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/enterprise-legacy/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/spring/4.3.0.RC1/xml/features</repository>
        <repository>mvn:org.apache.karaf.features/org.apache.karaf.features.extension/4.3.0.RC1/*</repository>

        <!--
        <repository>mvn:org.apache.karaf.features/spring-legacy/4.3.0-SNAPSHOT/xml/features</repository>
        <repository>mvn:org.ops4j.pax.web/pax-web-features/7.2.10/xml/features</repository>
        -->
        <repository>mvn:org.ops4j.pax.web/pax-web-features/7.2.11/xml/features</repository>
        <repository>mvn:org.ops4j.pax.web/pax-web-features/7.2.12/xml/features</repository>
    </blacklistedRepositories>
                    <bootFeatures>
                        <feature>standard</feature>
                        
                        <feature>scr</feature>
                        <feature>http-whiteboard</feature>
                         <feature>deployer/${karaf.version}</feature>
                         <feature>aries-blueprint/${karaf.version}</feature>
                         <feature>cxf-core/${cxf.version}</feature>
                         <feature>openjpa3/3.0.0</feature>
                         <feature>activemq-client/${activemq.version}</feature>
                         
                        <feature>bundle</feature>
                        <feature>config</feature>
                        <feature>diagnostic</feature>
                        <feature>feature</feature>
                        <feature>jaas</feature>
                        <feature>shell</feature>
                        <feature>log</feature>
                        <feature>management</feature>
                        <feature>package</feature>
                        <feature>shell-compat</feature>
                        <feature>ssh</feature>
                        <feature>system</feature>
                        <feature>wrap</feature>
                        <feature>wrapper</feature>

                        <feature>app</feature>
                         
                    </bootFeatures>
                    <installedFeatures>
                    </installedFeatures>
                    <javase>11</javase>
                </configuration>
                
<executions>
  <execution>
    <phase>compile</phase>
      <goals>
        <goal>assembly</goal>
      </goals>
    </execution>
    <execution>
      <id>package</id>
      <goals>
        <goal>archive</goal>
      </goals>
    </execution>
</executions>                
            </plugin>


It looks like the following is the problem

mvn:org.apache.karaf.features/org.apache.karaf.features.extension

I already played around with

<repository>mvn:org.apache.karaf.features/org.apache.karaf.features.extension/4.3.0.RC1/*</repository>

but got no positive result...

Thx & Regards,

Mike

The full error:

Feb 06, 2020 8:13:42 PM org.apache.karaf.main.Main launch
INFO: Installing and starting initial bundles
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.Main launch
INFO: All initial bundles installed and set to start
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.lock.SimpleFileLock lock
INFO: Trying to lock /Users/mikehummel/MHU/workspaces/crypta/doe-crypta/assembly/assembly-core/target/assembly/lock
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.lock.SimpleFileLock lock
INFO: Lock acquired
Feb 06, 2020 8:13:43 PM org.apache.karaf.main.Main$KarafLockCallback lockAcquired
INFO: Lock acquired. Setting startlevel to 100
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling SLF4J API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Jakarta Commons Logging API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Log4J API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Avalon Logger API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling JULI Logger API support.
org.ops4j.pax.logging.pax-logging-api[org.ops4j.pax.logging.internal.Activator] : Enabling Log4J v2 API support. Ignored FQCN: org.apache.logging.log4j.spi.AbstractLogger
20:13:43.917 WARN  [activator-1-thread-2] Old style feature file without namespace found (URI: mvn:org.apache.activemq/activemq-karaf/5.15.8/xml/features-core). This format is deprecated and support for it will soon be removed
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.989 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.990 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:43.990 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.011 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.012 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.012 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.012 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.013 WARN  [activator-1-thread-2] Matched URI can't use version ranges: mvn:org.apache.karaf.features/spring-legacy/[4,5)/xml/features
20:13:44.054 INFO  [activator-1-thread-2] Adding features: wrap/[2.6.2,2.6.2]
20:13:44.130 INFO  [features-3-thread-1] Changes to perform:
20:13:44.131 INFO  [features-3-thread-1]   Region: root
20:13:44.131 INFO  [features-3-thread-1]     Bundles to install:
20:13:44.131 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.url/pax-url-wrap/2.6.2/jar/uber
20:13:44.132 INFO  [features-3-thread-1] Installing bundles:
20:13:44.132 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.url/pax-url-wrap/2.6.2/jar/uber
20:13:44.152 INFO  [features-3-thread-1] Starting bundles:
20:13:44.153 INFO  [features-3-thread-1]   org.ops4j.pax.url.wrap/2.6.2
20:13:44.157 INFO  [features-3-thread-1] Done.
20:13:44.160 INFO  [activator-1-thread-2] Adding features: cxf-core/[3.3.1,3.3.1],wrapper/[4.2.6,4.2.6],framework/[4.2.6,4.2.6],openjpa3/[3.0.0,3.0.0],jaas/[4.2.6,4.2.6],package/[4.2.6,4.2.6],feature/[4.2.6,4.2.6],config/[4.2.6,4.2.6],http-whiteboard/[4.2.6,4.2.6],shell-compat/[4.2.6,4.2.6],scr/[4.2.6,4.2.6],deployer/[4.2.6,4.2.6],diagnostic/[4.2.6,4.2.6],shell/[4.2.6,4.2.6],management/[4.2.6,4.2.6],log/[4.2.6,4.2.6],crypta-core/[1.0.0.SNAPSHOT,1.0.0.SNAPSHOT],ssh/[4.2.6,4.2.6],system/[4.2.6,4.2.6],standard/[4.2.6,4.2.6],aries-blueprint/[4.2.6,4.2.6],activemq-client/[5.15.8,5.15.8],bundle/[4.2.6,4.2.6]
20:13:44.203 INFO  [features-3-thread-1] Changes to perform:
20:13:44.204 INFO  [features-3-thread-1]   Region: root
20:13:44.204 INFO  [features-3-thread-1]     Bundles to install:
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.2_1
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.jdbc/pax-jdbc/1.3.5
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.3.5
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.3.5
20:13:44.204 INFO  [features-3-thread-1]       mvn:org.osgi/org.osgi.service.jdbc/1.0.0
20:13:44.204 INFO  [features-3-thread-1] Installing bundles:
20:13:44.205 INFO  [features-3-thread-1]   mvn:org.apache.geronimo.specs/geronimo-jta_1.1_spec/1.1.1
20:13:44.208 INFO  [features-3-thread-1]   mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.jasypt/1.9.2_1
20:13:44.211 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.jdbc/pax-jdbc/1.3.5
20:13:44.213 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.jdbc/pax-jdbc-config/1.3.5
20:13:44.215 INFO  [features-3-thread-1]   mvn:org.ops4j.pax.jdbc/pax-jdbc-pool-common/1.3.5
20:13:44.217 INFO  [features-3-thread-1]   mvn:org.osgi/org.osgi.service.jdbc/1.0.0
20:13:44.232 INFO  [features-3-thread-1] Starting bundles:
20:13:44.233 INFO  [features-3-thread-1]   org.apache.geronimo.specs.geronimo-jta_1.1_spec/1.1.1
20:13:44.233 INFO  [features-3-thread-1]   org.osgi.service.jdbc/1.0.0.201505202023
20:13:44.234 INFO  [features-3-thread-1]   org.ops4j.pax.jdbc.pool.common/1.3.5
20:13:44.235 INFO  [features-3-thread-1]   org.ops4j.pax.jdbc/1.3.5
20:13:44.245 INFO  [features-3-thread-1]   org.apache.servicemix.bundles.jasypt/1.9.2.1
20:13:44.247 INFO  [features-3-thread-1]   org.ops4j.pax.jdbc.config/1.3.5
20:13:44.254 INFO  [features-3-thread-1] Obtained service dependency: (objectClass=org.ops4j.pax.jdbc.config.ConfigLoader)
20:13:44.255 INFO  [features-3-thread-1] Waiting for service dependency: (objectClass=org.ops4j.pax.jdbc.config.ConfigLoader)
20:13:44.260 INFO  [features-3-thread-1] Waiting for service dependency: (&(pool=*)(!(pax.jdbc.managed=true))(|(objectClass=javax.sql.DataSource)(objectClass=javax.sql.XADataSource)))
20:13:44.261 INFO  [features-3-thread-1] Done.
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=framework; type=karaf.feature; version="[4.2.6,4.2.6]"; filter:="(&(osgi.identity=framework)(type=karaf.feature)(version>=4.2.6)(version<=4.2.6))" [caused by: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
... 12 more
Caused by: org.apache.felix.resolver.reason.ReasonException: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)
at org.apache.felix.resolver.Candidates$FragmentNotSelectedError.toException(Candidates.java:1307)
... 13 more
20:13:45.259 ERROR [activator-1-thread-2] Error installing boot features
org.apache.felix.resolver.reason.ReasonException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=framework; type=karaf.feature; version="[4.2.6,4.2.6]"; filter:="(&(osgi.identity=framework)(type=karaf.feature)(version>=4.2.6)(version<=4.2.6))" [caused by: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:392)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378)
at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332)
at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257)
at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:393)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1062)
at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:998)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: org.apache.felix.resolver.reason.ReasonException: Unable to resolve framework/4.2.6: missing requirement [framework/4.2.6] osgi.identity; osgi.identity=org.apache.karaf.features.extension; type=osgi.fragment; version="[4.2.6,4.2.6]"; resolution:=mandatory [caused by: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)]
at org.apache.felix.resolver.Candidates$MissingRequirementError.toException(Candidates.java:1343)
... 12 more
Caused by: org.apache.felix.resolver.reason.ReasonException: Fragment was not selected for attachment: org.apache.karaf.features.extension [1](R 1.0)
at org.apache.felix.resolver.Candidates$FragmentNotSelectedError.toException(Candidates.java:1307)
... 13 more