Wait for feature install to complete

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Wait for feature install to complete

Paul Fraser
Hi,

The order of starting features can be controlled by using prerequisite in the feature tag.

What technique is available or what method can be used to prevent a feature being installed until a
prequisite feature has completed processing?

If I place feature1 (the prerequisite) in the install folder followed by placing feature2 in the
install folder all is OK.

Regards

Paul Fraser

Reply | Threaded
Open this post in threaded view
|

Re: Wait for feature install to complete

Paul Fraser
I mean the deploy folder, not the install folder...

On 26/09/2019 3:59 pm, Paul Fraser wrote:

> Hi,
>
> The order of starting features can be controlled by using prerequisite in the feature tag.
>
> What technique is available or what method can be used to prevent a feature being installed until
> a prequisite feature has completed processing?
>
> If I place feature1 (the prerequisite) in the install folder followed by placing feature2 in the
> install folder all is OK.
>
> Regards
>
> Paul Fraser
>

Reply | Threaded
Open this post in threaded view
|

Re: Wait for feature install to complete

jbonofre
In reply to this post by Paul Fraser
You can use inner feature with prerequisite="true".

Then you can first install the features repo containing the prerequisite
feature in the deploy folder, and then the second repo.

Generally speaking, I would recommend to use directly feature service
not via the deployer (not the deploy folder).

You can populate the Karaf system repo or use Cave repository and use
regular features service directly.

Regards
JB

On 26/09/2019 07:59, Paul Fraser wrote:

> Hi,
>
> The order of starting features can be controlled by using prerequisite
> in the feature tag.
>
> What technique is available or what method can be used to prevent a
> feature being installed until a prequisite feature has completed
> processing?
>
> If I place feature1 (the prerequisite) in the install folder followed by
> placing feature2 in the install folder all is OK.
>
> Regards
>
> Paul Fraser
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com