compilation failing with karaf 4.2.0.M2

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

compilation failing with karaf 4.2.0.M2

shivibansal
Hi All,

we were trying to upgrade KARAF version of our project to 4.2.0M2. rest of
the modules compiled fine but with build folder which generates the KAR
files, it fails while compilation with below error.

[ERROR] Failed to execute goal
org.apache.karaf.tooling:karaf-maven-plugin:4.2.0
.M2:verify (default-verify) on project gems-wrapper: Execution
default-verify of
 goal org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:verify failed:
Unable
 to load the mojo 'verify' (or one of its required components) from the
plugin '
org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2':
com.google.inject.Provisi
onException: Guice provision errors:
[ERROR]
[ERROR] 1) No implementation for
org.eclipse.aether.repository.WorkspaceReader w
as bound.
[ERROR] while locating org.apache.karaf.tooling.VerifyMojo
[ERROR] at
ClassRealm[plugin>org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M
2, parent: sun.misc.Launcher$AppClassLoader@5c647e05]
[ERROR] while locating org.apache.maven.plugin.Mojo annotated with
@com.google.i
nject.name.Named(value=org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:veri
fy)
[ERROR]
[ERROR] 1 error
[ERROR] role: org.apache.maven.plugin.Mojo
[ERROR] roleHint:
org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:verify
[ERROR] -> [Help 1]
[ERROR]

Can you please suggest?

Regards
Shivani



--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
Reply | Threaded
Open this post in threaded view
|

Re: compilation failing with karaf 4.2.0.M2

Grzegorz Grzybek
Which Maven version do you use?

regards
Grzegorz Grzybek

2018-03-08 14:31 GMT+01:00 shivibansal <[hidden email]>:

> Hi All,
>
> we were trying to upgrade KARAF version of our project to 4.2.0M2. rest of
> the modules compiled fine but with build folder which generates the KAR
> files, it fails while compilation with below error.
>
> [ERROR] Failed to execute goal
> org.apache.karaf.tooling:karaf-maven-plugin:4.2.0
> .M2:verify (default-verify) on project gems-wrapper: Execution
> default-verify of
>  goal org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:verify failed:
> Unable
>  to load the mojo 'verify' (or one of its required components) from the
> plugin '
> org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2':
> com.google.inject.Provisi
> onException: Guice provision errors:
> [ERROR]
> [ERROR] 1) No implementation for
> org.eclipse.aether.repository.WorkspaceReader w
> as bound.
> [ERROR] while locating org.apache.karaf.tooling.VerifyMojo
> [ERROR] at
> ClassRealm[plugin>org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M
> 2, parent: sun.misc.Launcher$AppClassLoader@5c647e05]
> [ERROR] while locating org.apache.maven.plugin.Mojo annotated with
> @com.google.i
> nject.name.Named(value=org.apache.karaf.tooling:karaf-
> maven-plugin:4.2.0.M2:veri
> fy)
> [ERROR]
> [ERROR] 1 error
> [ERROR] role: org.apache.maven.plugin.Mojo
> [ERROR] roleHint:
> org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:verify
> [ERROR] -> [Help 1]
> [ERROR]
>
> Can you please suggest?
>
> Regards
> Shivani
>
>
>
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
>
Reply | Threaded
Open this post in threaded view
|

Re: compilation failing with karaf 4.2.0.M2

jbonofre
In reply to this post by shivibansal
Hi,

are you using Maven 3.5.x ?

Regards
JB

On 03/08/2018 02:31 PM, shivibansal wrote:

> Hi All,
>
> we were trying to upgrade KARAF version of our project to 4.2.0M2. rest of
> the modules compiled fine but with build folder which generates the KAR
> files, it fails while compilation with below error.
>
> [ERROR] Failed to execute goal
> org.apache.karaf.tooling:karaf-maven-plugin:4.2.0
> .M2:verify (default-verify) on project gems-wrapper: Execution
> default-verify of
>  goal org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:verify failed:
> Unable
>  to load the mojo 'verify' (or one of its required components) from the
> plugin '
> org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2':
> com.google.inject.Provisi
> onException: Guice provision errors:
> [ERROR]
> [ERROR] 1) No implementation for
> org.eclipse.aether.repository.WorkspaceReader w
> as bound.
> [ERROR] while locating org.apache.karaf.tooling.VerifyMojo
> [ERROR] at
> ClassRealm[plugin>org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M
> 2, parent: sun.misc.Launcher$AppClassLoader@5c647e05]
> [ERROR] while locating org.apache.maven.plugin.Mojo annotated with
> @com.google.i
> nject.name.Named(value=org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:veri
> fy)
> [ERROR]
> [ERROR] 1 error
> [ERROR] role: org.apache.maven.plugin.Mojo
> [ERROR] roleHint:
> org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:verify
> [ERROR] -> [Help 1]
> [ERROR]
>
> Can you please suggest?
>
> Regards
> Shivani
>
>
>
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

Re: compilation failing with karaf 4.2.0.M2

Grzegorz Grzybek
The change was done in Maven 3.3.x times

~Grzegorz

2018-03-08 14:33 GMT+01:00 Jean-Baptiste Onofré <[hidden email]>:

> Hi,
>
> are you using Maven 3.5.x ?
>
> Regards
> JB
>
> On 03/08/2018 02:31 PM, shivibansal wrote:
> > Hi All,
> >
> > we were trying to upgrade KARAF version of our project to 4.2.0M2. rest
> of
> > the modules compiled fine but with build folder which generates the KAR
> > files, it fails while compilation with below error.
> >
> > [ERROR] Failed to execute goal
> > org.apache.karaf.tooling:karaf-maven-plugin:4.2.0
> > .M2:verify (default-verify) on project gems-wrapper: Execution
> > default-verify of
> >  goal org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:verify
> failed:
> > Unable
> >  to load the mojo 'verify' (or one of its required components) from the
> > plugin '
> > org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2':
> > com.google.inject.Provisi
> > onException: Guice provision errors:
> > [ERROR]
> > [ERROR] 1) No implementation for
> > org.eclipse.aether.repository.WorkspaceReader w
> > as bound.
> > [ERROR] while locating org.apache.karaf.tooling.VerifyMojo
> > [ERROR] at
> > ClassRealm[plugin>org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M
> > 2, parent: sun.misc.Launcher$AppClassLoader@5c647e05]
> > [ERROR] while locating org.apache.maven.plugin.Mojo annotated with
> > @com.google.i
> > nject.name.Named(value=org.apache.karaf.tooling:karaf-
> maven-plugin:4.2.0.M2:veri
> > fy)
> > [ERROR]
> > [ERROR] 1 error
> > [ERROR] role: org.apache.maven.plugin.Mojo
> > [ERROR] roleHint:
> > org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:verify
> > [ERROR] -> [Help 1]
> > [ERROR]
> >
> > Can you please suggest?
> >
> > Regards
> > Shivani
> >
> >
> >
> > --
> > Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
> >
>
> --
> Jean-Baptiste Onofré
> [hidden email]
> http://blog.nanthrax.net
> Talend - http://www.talend.com
>
Reply | Threaded
Open this post in threaded view
|

Re: compilation failing with karaf 4.2.0.M2

jbonofre
Yeah, I'm suspecting he doesn't use Maven 3.5.x (probably 3.2.x).

Regards
JB

On 03/08/2018 02:35 PM, Grzegorz Grzybek wrote:

> The change was done in Maven 3.3.x times
>
> ~Grzegorz
>
> 2018-03-08 14:33 GMT+01:00 Jean-Baptiste Onofré <[hidden email]>:
>
>> Hi,
>>
>> are you using Maven 3.5.x ?
>>
>> Regards
>> JB
>>
>> On 03/08/2018 02:31 PM, shivibansal wrote:
>>> Hi All,
>>>
>>> we were trying to upgrade KARAF version of our project to 4.2.0M2. rest
>> of
>>> the modules compiled fine but with build folder which generates the KAR
>>> files, it fails while compilation with below error.
>>>
>>> [ERROR] Failed to execute goal
>>> org.apache.karaf.tooling:karaf-maven-plugin:4.2.0
>>> .M2:verify (default-verify) on project gems-wrapper: Execution
>>> default-verify of
>>>  goal org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:verify
>> failed:
>>> Unable
>>>  to load the mojo 'verify' (or one of its required components) from the
>>> plugin '
>>> org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2':
>>> com.google.inject.Provisi
>>> onException: Guice provision errors:
>>> [ERROR]
>>> [ERROR] 1) No implementation for
>>> org.eclipse.aether.repository.WorkspaceReader w
>>> as bound.
>>> [ERROR] while locating org.apache.karaf.tooling.VerifyMojo
>>> [ERROR] at
>>> ClassRealm[plugin>org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M
>>> 2, parent: sun.misc.Launcher$AppClassLoader@5c647e05]
>>> [ERROR] while locating org.apache.maven.plugin.Mojo annotated with
>>> @com.google.i
>>> nject.name.Named(value=org.apache.karaf.tooling:karaf-
>> maven-plugin:4.2.0.M2:veri
>>> fy)
>>> [ERROR]
>>> [ERROR] 1 error
>>> [ERROR] role: org.apache.maven.plugin.Mojo
>>> [ERROR] roleHint:
>>> org.apache.karaf.tooling:karaf-maven-plugin:4.2.0.M2:verify
>>> [ERROR] -> [Help 1]
>>> [ERROR]
>>>
>>> Can you please suggest?
>>>
>>> Regards
>>> Shivani
>>>
>>>
>>>
>>> --
>>> Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
>>>
>>
>> --
>> Jean-Baptiste Onofré
>> [hidden email]
>> http://blog.nanthrax.net
>> Talend - http://www.talend.com
>>
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

Re: compilation failing with karaf 4.2.0.M2

shivibansal
On my system, I have maven installed as 3.0.5.

but in the codebase pom files, I have changed properties to
 <apache-karaf.version>4.2.0.M2</apache-karaf.version>
 
<apache-karaf.maven.plugin.version>4.2.0.M2</apache-karaf.maven.plugin.version>

Shall i update the maven version on my system?

Regards
Shivani



--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
Reply | Threaded
Open this post in threaded view
|

Re: compilation failing with karaf 4.2.0.M2

Andrea Cosentino
yes, you have to update it.

--
Andrea Cosentino 
----------------------------------
Apache Camel PMC Member
Apache Karaf Committer
Apache Servicemix PMC Member
Email: [hidden email]
Twitter: @oscerd2
Github: oscerd






On Thursday, March 8, 2018, 2:45:05 PM GMT+1, shivibansal <[hidden email]> wrote:





On my system, I have maven installed as 3.0.5.

but in the codebase pom files, I have changed properties to
<apache-karaf.version>4.2.0.M2</apache-karaf.version>

<apache-karaf.maven.plugin.version>4.2.0.M2</apache-karaf.maven.plugin.version>

Shall i update the maven version on my system?


Regards
Shivani



--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
Reply | Threaded
Open this post in threaded view
|

Re: compilation failing with karaf 4.2.0.M2

jbonofre
In reply to this post by shivibansal
Yes, you have to use Maven >= 3.3.x.

Regards
JB

On 03/08/2018 02:45 PM, shivibansal wrote:

> On my system, I have maven installed as 3.0.5.
>
> but in the codebase pom files, I have changed properties to
>  <apache-karaf.version>4.2.0.M2</apache-karaf.version>
>  
> <apache-karaf.maven.plugin.version>4.2.0.M2</apache-karaf.maven.plugin.version>
>
> Shall i update the maven version on my system?
>
> Regards
> Shivani
>
>
>
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com
Reply | Threaded
Open this post in threaded view
|

Re: compilation failing with karaf 4.2.0.M2

shivibansal
In reply to this post by Andrea Cosentino
Ok Thx, I will update it to 3.5.3.

Regards
Shivani



--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
Reply | Threaded
Open this post in threaded view
|

Re: compilation failing with karaf 4.2.0.M2

Grzegorz Grzybek
Good idea - and enjoy console colors!

cheers
Grzegorz Grzybek

2018-03-08 14:49 GMT+01:00 shivibansal <[hidden email]>:

> Ok Thx, I will update it to 3.5.3.
>
> Regards
> Shivani
>
>
>
> --
> Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html
>
Reply | Threaded
Open this post in threaded view
|

Re: compilation failing with karaf 4.2.0.M2

shivibansal
Thanks all, it was compiled successfully with latest maven version



--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html