karaf 4.2.0 and activemq

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

karaf 4.2.0 and activemq

lacigas
Hi
I wanted to upgrade our karaf 4.0.5 installation with a newer one and
I'm having trouble with the activemq bundle.

I managed to upgrade to karaf 4.1.5 with

feature:repo-add mvn:org.apache.activemq/activemq-karaf/5.14.4/xml/features
feature:install activemq

But when I try to upgrade to karaf 4.2 then I can't find an activemq
version which works. I alwas get:
Unable to resolve activemq-client/5.15.4: missing requirement
[activemq-client/5.15.4]

Thanks for your help.
Cheers,
Laci
Reply | Threaded
Open this post in threaded view
|

Re: karaf 4.2.0 and activemq

jbonofre
Hi Laci,

On Karaf 4.2, you can do:

feature:repo-add activemq 5.15.0

Then, it depends what you want to install:

feature:install activemq-client

provides the connection factory (that you can use with jms feature/service).

feature:install activemq-broker

installs the ActiveMQ broker in Karaf.

Regards
JB

On 24/05/2018 11:06, Laci Gaspar wrote:

> Hi
> I wanted to upgrade our karaf 4.0.5 installation with a newer one and
> I'm having trouble with the activemq bundle.
>
> I managed to upgrade to karaf 4.1.5 with
>
> feature:repo-add mvn:org.apache.activemq/activemq-karaf/5.14.4/xml/features
> feature:install activemq
>
> But when I try to upgrade to karaf 4.2 then I can't find an activemq
> version which works. I alwas get:
> Unable to resolve activemq-client/5.15.4: missing requirement
> [activemq-client/5.15.4]
>
> Thanks for your help.
> Cheers,
> Laci
Reply | Threaded
Open this post in threaded view
|

Re: karaf 4.2.0 and activemq

jbonofre
In reply to this post by lacigas
By the way,

you have to install aries-blueprint feature first:

feature:install aries-blueprint

and add the spring-legacy repo:

feature:repo-add spring-legacy

Regards
JB

On 24/05/2018 11:06, Laci Gaspar wrote:

> Hi
> I wanted to upgrade our karaf 4.0.5 installation with a newer one and
> I'm having trouble with the activemq bundle.
>
> I managed to upgrade to karaf 4.1.5 with
>
> feature:repo-add mvn:org.apache.activemq/activemq-karaf/5.14.4/xml/features
> feature:install activemq
>
> But when I try to upgrade to karaf 4.2 then I can't find an activemq
> version which works. I alwas get:
> Unable to resolve activemq-client/5.15.4: missing requirement
> [activemq-client/5.15.4]
>
> Thanks for your help.
> Cheers,
> Laci
Reply | Threaded
Open this post in threaded view
|

Re: karaf 4.2.0 and activemq

jbonofre
You are welcome.

Regards
JB

On 24/05/2018 11:24, Laci Gaspar wrote:

> Thanks a lot for your quick answer. That worked!
>
> regards,
> Laci
>
> Am 24.05.2018 um 11:12 schrieb Jean-Baptiste Onofré:
>> By the way,
>>
>> you have to install aries-blueprint feature first:
>>
>> feature:install aries-blueprint
>>
>> and add the spring-legacy repo:
>>
>> feature:repo-add spring-legacy
>>
>> Regards
>> JB
>>
>> On 24/05/2018 11:06, Laci Gaspar wrote:
>>> Hi
>>> I wanted to upgrade our karaf 4.0.5 installation with a newer one and
>>> I'm having trouble with the activemq bundle.
>>>
>>> I managed to upgrade to karaf 4.1.5 with
>>>
>>> feature:repo-add
>>> mvn:org.apache.activemq/activemq-karaf/5.14.4/xml/features
>>> feature:install activemq
>>>
>>> But when I try to upgrade to karaf 4.2 then I can't find an activemq
>>> version which works. I alwas get:
>>> Unable to resolve activemq-client/5.15.4: missing requirement
>>> [activemq-client/5.15.4]
>>>
>>> Thanks for your help.
>>> Cheers,
>>> Laci
>