two chains verification of packages - how to avoid that

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

two chains verification of packages - how to avoid that

billtsay
karaf@root()> install -s
mvn:org.apache.cxf.samples/jax_rs_description_swagger2_osgi/3.2.4
Bundle ID: 207
Error executing command: Error installing bundles:
        Unable to start bundle
mvn:org.apache.cxf.samples/jax_rs_description_swagger2_osgi/3.2.4:
org.osgi.framework.BundleException: Uses constraint violation. Unable to
resolve resource org.apache.cxf.samples.jax_rs_description_swagger2_osgi
[org.apache.cxf.samples.jax_rs_description_swagger2_osgi [207](R 207.0)]
because it is exposed to package 'javax.annotation' from resources
javax.annotation-api [javax.annotation-api [111](R 111.0)] and
org.apache.felix.framework [org.apache.felix.framework [0](R 0)] via two
dependency chains.

Chain 1:
  org.apache.cxf.samples.jax_rs_description_swagger2_osgi
[org.apache.cxf.samples.jax_rs_description_swagger2_osgi [207](R 207.0)]
    import:
(&(osgi.wiring.package=javax.annotation)(version>=1.2.0)(!(version>=2.0.0)))
     |
    export: osgi.wiring.package: javax.annotation
  javax.annotation-api [javax.annotation-api [111](R 111.0)]

Chain 2:
  org.apache.cxf.samples.jax_rs_description_swagger2_osgi
[org.apache.cxf.samples.jax_rs_description_swagger2_osgi [207](R 207.0)]
    import:
(&(osgi.wiring.package=io.swagger.jaxrs.config)(version>=1.5.0)(!(version>=2.0.0)))
     |
    export: osgi.wiring.package=io.swagger.jaxrs.config;
uses:=org.reflections.util
  io.swagger.jaxrs [io.swagger.jaxrs [197](R 197.0)]
    import:
(&(osgi.wiring.package=org.reflections.util)(version>=0.9.0)(!(version>=1.0.0)))
     |
    export: osgi.wiring.package=org.reflections.util; uses:=javax.annotation
  org.apache.servicemix.bundles.reflections
[org.apache.servicemix.bundles.reflections [203](R 203.0)]
    import: (osgi.wiring.package=javax.annotation)
     |
    export: osgi.wiring.package: javax.annotation
  org.apache.felix.framework [org.apache.felix.framework [0](R 0)]
Unresolved requirements:
[[org.apache.cxf.samples.jax_rs_description_swagger2_osgi [207](R 207.0)]
osgi.wiring.package;
(&(osgi.wiring.package=io.swagger.jaxrs.config)(version>=1.5.0)(!(version>=2.0.0)))]




--
Sent from: http://karaf.922171.n3.nabble.com/Karaf-Dev-f930721.html